Rockbox

Tasklist

FS#10505 - Background changes to inverted when cleared

Attached to Project: Rockbox
Opened by Jim Henderson (hendersj) - Monday, 10 August 2009, 22:19 GMT
Last edited by Thomas Martitz (kugel.) - Wednesday, 12 August 2009, 13:05 GMT
Task Type Bugs
Category LCD
Status Closed
Assigned To No-one
Operating System iPod Mini
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Currently running build 22244 - though this seems to have crept in an earlier release within the past couple of days.

I'm using a theme that I've cleared the background image for - when starting RB, the screen changes to inverted where prior to a few days ago, the menu was displayed normally (ie, not with a solid black background). Unfortunately, the text is also displayed black, so all I see are the icons.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Wednesday, 12 August 2009, 13:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed r22264, thanks for finding the revision causing it.
Comment by Thomas Martitz (kugel.) - Monday, 10 August 2009, 23:19 GMT
can't reproduce here.
Comment by Jim Henderson (hendersj) - Tuesday, 11 August 2009, 00:49 GMT
I've reproduced it here using both themes that include no background and selecting the "cabbiev2" theme and clearing the background. To make sure it wasn't caused by something related to earlier builds, I wiped the .rockbox directory from my iPod and reinstalled and was able to duplicate then as well.
Comment by Thomas Martitz (kugel.) - Tuesday, 11 August 2009, 04:03 GMT
I tried clearing the backdrop on the e200. After a reboot, the background was black, but the font was white, so as expected I suppose.
Comment by Jim Henderson (hendersj) - Tuesday, 11 August 2009, 14:55 GMT
I've done a little poking around and rebuilt various builds to try to identify where the issue appeared. Here's what I've found:

Build 22221 doesn't have this issue

Build 22224 does have the issue

Builds 22222-22223 won't build for me.

Is your e200 a colour device or a greyscale device?
Comment by Jim Henderson (hendersj) - Tuesday, 11 August 2009, 15:01 GMT
This also is reproducible in the simulator - configure for iPod Mini 1G (option 25) and you should be able to reproduce it.
Comment by Alexander Levin (fml2) - Wednesday, 12 August 2009, 12:50 GMT
Confirmed in the simulator for H120, r22263. Reset settings (->everything is OK), then cleared the backdrop image (->the screen of the main unit is drawn black).

Loading...