Rockbox

Tasklist

FS#10527 - Clicking in Ver 3.3 Ipod 5gen.

Attached to Project: Rockbox
Opened by Drew Nielsen (Railight) - Saturday, 15 August 2009, 07:33 GMT
Last edited by Dave Hooper (stripwax) - Sunday, 18 October 2009, 01:51 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Version 3.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I would like to report a bug with RB ver 3.3 on a 5gen Ipod.
When playing flac files I get a random clicking sound in the left channel.
I have 2 5 gen ipods (60gb and 80gb) and they both do this with Ver 3.3.
I reinstalled Ver 3.3 and it still clicks.
When I went back to Ver 3.1 this clicking stopped.
This sound is very similar to the clicking in Ver 3.2 that was fixed, but not as frequent.
This sound can be heard on more than 1 file. I moved one of the files that was doing this to my computer and played it using Zoomplayer and no clicking.
Thanks for all the great work, Rockbox is great.
This task depends upon

Closed by  Dave Hooper (stripwax)
Sunday, 18 October 2009, 01:51 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Issue was nothing to do with audio files / codecs but rather a CPU resource issue. A new bug task opened to reflect this.
Comment by Boris Gjenero (dreamlayers) - Monday, 17 August 2009, 23:16 GMT
Can you try to narrow down the problem to a specific SVN revision? Can you provide a file which triggers this problem? I wonder if the  FS#10111  change in r20671 (for pops in 24 bit FLAC files) is responsible because I don't see any other changes to the FLAC codec which could cause this.

You can build the FLAC codec into a standalone test executable which decodes FLAC files to WAV files. Use "make -f Makefile.test" in the apps/codecs/libffmpegFLAC directory. The output files ought to be identical to those created by "flac -d file.flac".
Comment by Drew Nielsen (Railight) - Wednesday, 19 August 2009, 16:23 GMT
I can send a file that does this if I knew where to send it. I appologize but have to admit I dont really know enough to be able to follow the rest of the instructions mentioned.
Comment by Boris Gjenero (dreamlayers) - Wednesday, 19 August 2009, 17:01 GMT
Can you decode the FLAC file into a WAV file, play the WAV file on an iPod, and see if there are clicks? You can get FLAC software at http://flac.sourceforge.net/download.html . At the command line, decoding can be accomplished via: flac -d "filename.flac"

If a file is under the Gmail attachment size limit, feel free to e-mail it to boris.gjenero at gmail. There are also other services for sending files such as http://streamfile.com/ .
Comment by Drew Nielsen (Railight) - Wednesday, 19 August 2009, 17:33 GMT
I can send a file that does this if I knew where to send it. I appologize but have to admit I dont really know enough to be able to follow the rest of the instructions mentioned.
Comment by Drew Nielsen (Railight) - Wednesday, 19 August 2009, 17:36 GMT
I downloaded the FLAC frontend from sourceforge and decoded one of the files in question to WAV and loaded into my ipod 80gb running RB 3.3 and to my amazement it is also clicking.

Now what?
Comment by Drew Nielsen (Railight) - Wednesday, 19 August 2009, 17:51 GMT
I have sent an Email containing a FLAC file to you.
Comment by Drew Nielsen (Railight) - Thursday, 20 August 2009, 05:37 GMT
It seems this problem has been corrected after resetting the settings back to the default settings. At this point I am unsure what exactly was causing it.
Comment by Drew Nielsen (Railight) - Sunday, 30 August 2009, 02:40 GMT
After much playing around I have come to the conclusion that this is only happening when using the rockbox default wps screen, the one with the peak meter. When I switch to anything else it goes away. Any comments would be appreciated.
Comment by Andree Buschmann (Buschel) - Sunday, 30 August 2009, 17:23 GMT
Sounds like too high CPU-load, the peak meter needs a lot of CPU.
Comment by Dave Hooper (stripwax) - Sunday, 18 October 2009, 01:50 GMT
Closing. Peakmeter does indeed need a lot of CPU on ipod. If you turn off peakmeter, or use a WPS without peakmeter, or navigate away from the WPS to a different screen (e.g. menu, file browser) the problem will not surface. I will open another bug task instead, with the issue being that peakmeter uses too much CPU during flac/wav decode.

Loading...