Rockbox

Tasklist

FS#10586 - c200(v2): right button in time setting menu exits menu

Attached to Project: Rockbox
Opened by Bertrik Sikken (bertrik) - Saturday, 05 September 2009, 02:59 GMT
Last edited by Bertrik Sikken (bertrik) - Sunday, 13 September 2009, 11:40 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Sansa c200
Severity Low
Priority Normal
Reported Version Version 3.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Both on the c200 and the c200v2, a short press on the right button in the time setting menu (System / Time & Date / Set Time/Date) causes the player to exit the time menu instead of going to the next time item (e.g. hours -> minutes). Holding the right button slightly longer does make the player go to the next time item.

To reproduce: go to menu System / Time & Date / Set Time/Date, briefly press the right button. The menu is exited (setting is accepted).

Possible cause:
Time menu buttons are handled by button context button_context_settings which defines ACTION_STD_NEXT as BUTTON_NONE->BUTTON_RIGHT and seems to inherit from CONTEXT_STD. However button context button_context_standard defines an ACTION_STD_OK as BUTTON_RIGHT->BUTTON_RIGHT|BUTTON_REL.
So a short press on the right button probably causes both a ACTION_STD_NEXT and a ACTION_STD_OK action, which makes it exit the time settings menu.

Probably related to the change in SVN r21373 ( FS#8824 )
This task depends upon

Closed by  Bertrik Sikken (bertrik)
Sunday, 13 September 2009, 11:40 GMT
Reason for closing:  Accepted
Additional comments about closing:  Committed as svn r22692
Comment by Bertrik Sikken (bertrik) - Saturday, 05 September 2009, 03:22 GMT
Attached patch makes going left/right in the time settings menu work again. Not sure if this has any side effects, haven't tested thoroughly yet.
Comment by Bertrik Sikken (bertrik) - Saturday, 05 September 2009, 19:25 GMT
Attached patch is another way of solving it, this simply maps the offending combination to ACTION_NONE, so it no longer falls through in actions of button_context_standard.
Comment by Bertrik Sikken (bertrik) - Monday, 07 September 2009, 18:13 GMT
A similar problem exists in the color adjustment screen (e.g.Theme settings / Colours / Line Selector Colours). A short press right seems to be interpreted as OK/Accept.
Comment by Bertrik Sikken (bertrik) - Sunday, 13 September 2009, 11:36 GMT
Attached patch fixes both the time/date menu and the colour chooser screen by assigning ACTION_NONE to the release of button left or right in their respective context keymaps.

Loading...