Rockbox

Tasklist

FS#10595 - First skin_line in a conditional vp is is also part of the previous vp

Attached to Project: Rockbox
Opened by Thomas Martitz (kugel.) - Tuesday, 08 September 2009, 11:17 GMT
Last edited by Thomas Martitz (kugel.) - Tuesday, 08 September 2009, 16:35 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To Jonathan Gordon (jdgordon)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

So, I noticed a visual glitch with the Azure Ultimate theme (http://themes.rockbox.org/index.php?target=e200) where a grey bar would show in the progressbar viewport (which is defined above). See http://imagebin.org/62908 (this is actually with the custom statusbar patch, but the same problem happens in SVN with the non-custom-sb version of the theme).

It turns out that it was caused by r22618.

I moved the progressbar viewport away, which made that grey bar show up in the viewport that was above progressbar one. I also saw the grey bar is actually the top few pixels of a the keypad locked image (the keypad locked image shows instead of "Now Playing" at the very top if hold is on).

This means: The this image is in a conditional viewport, and shows up in the viewport defined above. It also shows in the viewport it's defined in.

I've attached a patch which seems to fix it (the line is suspicious because an index should be always num_* -1 (if index is starting with 0, and num_ with 1) ? ). But I have no idea if that's the proper fix. I also have no idea why it apparently only happens with condition viewports, but that may just be my theme which triggers it.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Tuesday, 08 September 2009, 16:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in r22662.

Loading...