Rockbox

Tasklist

FS#10597 - Loadable keyboard layout rendered incorrectly

Attached to Project: Rockbox
Opened by Delyan Kratunov (archivator) - Thursday, 10 September 2009, 21:17 GMT
Last edited by Teruaki Kawashima (teru) - Saturday, 03 October 2009, 14:51 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The first time you load a keyboard layout or start rockbox, the virtual keyboard is displayed properly. The next time you open it, however, it is rendered with a fixed width font and completely disregards the number of lines in the original file. Thus, it makes loadable layouts unusable.

I last tested with r22668 but this has been going on for a while now.
This task depends upon

Closed by  Teruaki Kawashima (teru)
Saturday, 03 October 2009, 14:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  Should be fixed in r22892.
Please open a new task if there is still issue.
Comment by PaulJam (PaulJam) - Friday, 11 September 2009, 09:42 GMT
Could you attach the .kbd file and a screendump that displays the problem? I'm using a custom layout and haven't seen anything unusual in the virtual keyboard with the current build (r22675).
Comment by Delyan Kratunov (archivator) - Saturday, 12 September 2009, 09:11 GMT
Here you go! 110823 shows the properly rendered keyboard, the next one - the incorrectly rendered one. Both taken on ipodvideo 32GB. I couldn't reproduce this behavior in a sim.
Comment by Teruaki Kawashima (teru) - Saturday, 12 September 2009, 13:31 GMT
this hopefully fix issue.
it seems like that max width is set to the width of the '\n' character when kbd_input is called first time after loaded the kbd.
but '\n' in kbd_buf is replaced by the spaces filling the line later. and max width becomes smaller when kbd_input is called next time.
Comment by Delyan Kratunov (archivator) - Saturday, 12 September 2009, 23:08 GMT
While the patch makes the virtual keyboard consistent (and properly rendered), it is now rendered with a different font (the UI one instead of the one I selected). I don't find it that much of an inconvenience but it would be nice if it would render as it did previously (see attached screenshot for clarification; compare with 110823 above).
Comment by Teruaki Kawashima (teru) - Sunday, 13 September 2009, 01:51 GMT
I don't think different font is used. the difference is margin between two characters decided by lagest width among characters in kbd.
adding wider character(e.g. tab) to .kbd file would render the virtual keyboard like 110823.
Comment by Delyan Kratunov (archivator) - Wednesday, 23 September 2009, 20:29 GMT
I won't discuss the spacing until I'm sure I know what I'm talking about so let's leave that for now.

There's, however, another issue I noticed when using your patch - the input line gets cut off at the end of the keyboard layout, wasting almost half the screen space to the right. See screendump for clarification.
Comment by Teruaki Kawashima (teru) - Saturday, 26 September 2009, 14:00 GMT
Does this one fix the issue?

Loading...