Rockbox

Tasklist

FS#10635 - Playback crashes on starting pitch detector plugin

Attached to Project: Rockbox
Opened by Jan (dumbo20) - Friday, 02 October 2009, 14:58 GMT
Last edited by Nils Wallménius (nls) - Friday, 14 May 2010, 07:58 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I start the pitch detector plugin on a Sansa e250v1 while music is playing, rockbox crashes. The playback freezes and the player only shows the background graphic, without any text and doesn't react on keypress. Only pressing poweroff for 10 sec helps then.

Reported on Rockbox 3.4 with many different file formats, as wma, flac and mp3.
This task depends upon

Closed by  Nils Wallménius (nls)
Friday, 14 May 2010, 07:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in r26002 and/or 26005
Comment by Hilton Shumway (HIllshum) - Saturday, 03 October 2009, 01:27 GMT
This looks like a duplicate of #10634
Comment by Dominik Riebeling (bluebrother) - Saturday, 03 October 2009, 09:12 GMT
This is indeed a duplicate of  FS#10634 . Keeping this open as it holds slightly more information.
Comment by Mazrim Taim (MHael) - Thursday, 15 October 2009, 11:19 GMT
This is not player specific, I was just about to submit this bug myself.

Ipod Nano 1G 4GB
I have tried this in:
-Release 3.4
-r23178-091014 (Today's daily build)
-r23180-091015 (The current build)
-r23123-091012 (An older daily build)

This does not cause a crash in the Nano simulator (r23131-091012)

Rockbox will crash/freeze showing only the backdrop image, requiring a reset.
Comment by Sal Mazzola (sal) - Monday, 09 November 2009, 21:43 GMT
Pitch_detector crashes for me as well (r23594-091109 e280v1). Right from startup, I go to plugins->applications->pitch_detector. The meter appears on the bottom of the screen, and about a second later, the screen goes blank (backlight stays on). Hard reset is the only thing that works.
Comment by Nils Wallménius (nls) - Saturday, 05 December 2009, 09:59 GMT
i looked a bit at this abd found some interesting things:
*it works fine on my h300, music even keeps playing fine while using the plugin
*crashes on c200 if playback is running when it's started
*crash on c200 is fixed if calling rb->pcm_play_stop *and* adding a small sleep inside that function so that is sleeps with the dma ints disabled.
I guess this is caused by two different issues
1) the pcm-pp driver likely doesn't handle simultaneous playback and recording well (this is a guess)
2) waiting for DMA transfers to finish in pp-pcm.c:play_stop_pcm() doesn't work correctly, making ints fire after the function returns. (also not quite sure about this one but seems to be supported by my investigations)
Comment by Mazrim Taim (MHael) - Friday, 05 February 2010, 14:36 GMT
Bug still exists in 3.5
Comment by Frieder Ferlemann (frief) - Monday, 15 February 2010, 14:33 GMT
I can confirm the bug still exists in 3.5 and r24667-100215. Sansa e250v1

Loading...