Rockbox

Tasklist

FS#10674 - Wrong error line numbers in simulator log on errors in WPS file.

Attached to Project: Rockbox
Opened by Marc Aarts (topik) - Tuesday, 13 October 2009, 19:28 GMT
Last edited by Jonathan Gordon (jdgordon) - Thursday, 03 December 2009, 05:37 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The simulator gives wrong error line numbers on WPS errors. The line number shown is higher than the actual line with the error.

JdGordon on IRC gave this reply: i tihnk i know what the problem is.. I tihnk tokens which take up the whole line dont increment the line counter... (like the %xl| lines)

Tested on ipod nano 1G simulator r23131-091012
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Thursday, 03 December 2009, 05:37 GMT
Reason for closing:  Fixed

Loading...