Rockbox

Tasklist

FS#10684 - stereo channels swap after pause - resume

Attached to Project: Rockbox
Opened by Turke (obzen) - Sunday, 18 October 2009, 00:50 GMT
Last edited by Michael Sparmann (TheSeven) - Wednesday, 21 October 2009, 18:54 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod Nano 2G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

All songs start with the original stereo channels, no problem on that. But whenever you pause and resume quickly, you can notice that the stereo channels have swapped, right becoming left, and left becoming right. If you pause and resume again in a quick manner, stereo channels do swap again, to the original output positions. This actions repeats itself in every fast pause - resume action.

ipod nano - 2nd generation.
This task depends upon

Closed by  Michael Sparmann (TheSeven)
Wednesday, 21 October 2009, 18:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fix committed in r23308
Comment by Turke (obzen) - Sunday, 18 October 2009, 08:38 GMT
After a quick review, i noticed that you don't even have to be quick for the channels to swap. Most pause - resume actions do swap the channels, quick or not.
Comment by Michael Sparmann (TheSeven) - Sunday, 18 October 2009, 12:13 GMT
Did you ever happen to have a pause/resume that didn't swap them? If it's happening 100% of the cases, it will be relatively easy to fix.
Comment by Turke (obzen) - Sunday, 18 October 2009, 13:54 GMT
Well, it happens like 90% of the cases as far as i tried. The channels left unchanged only a few times after resume. Don't know why.
Comment by Michael Sparmann (TheSeven) - Tuesday, 20 October 2009, 08:03 GMT
I think I've caught it. Can you re-test using the attached rockbox.ipod file?
Comment by Turke (obzen) - Tuesday, 20 October 2009, 10:13 GMT
That didn't fix it, i'm sorry. Still the same.
Comment by Michael Sparmann (TheSeven) - Tuesday, 20 October 2009, 13:53 GMT
Weird. It seemed to fix it for me. I'll have another look at it soon

Loading...