Rockbox

Tasklist

FS#10694 - Audio player selection is not visible while window is out of focus

Attached to Project: Rockbox
Opened by Tomer Shalev (tomers) - Tuesday, 20 October 2009, 05:38 GMT
Last edited by Dominik Riebeling (bluebrother) - Wednesday, 11 January 2012, 20:42 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Please refer to the two screen shots.
In one of them the audio players list in the configuration window is in focus, and the selected player is clearly visible. In the other it is not visible, as this widget is out of focus.
Using Windows XP, default theme.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Wednesday, 11 January 2012, 20:42 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  1. It is not necessary to clearly show the selected player when the window is out of focus -- the selection is important when making the selection, and for that the window has to have the focus.
2. Rockbox Utility hilights the detected player in bold, which should make it easy to spot it.
3. As said before, this is not a Rockbox Utility issue but a theme issue of Qt. This could be (somewhat) avoided by disabling the alternating line background, but the improved readability is worth it.
Comment by Tomer Shalev (tomers) - Tuesday, 20 October 2009, 05:39 GMT
The other screenshot
Comment by Dominik Wenger (Domonoky) - Tuesday, 20 October 2009, 21:18 GMT
I can still see a selection in the first screenshot. :-)
But i agree that this is not very visible only a faint grey.
Maybe we should try to change the color scheme for this list.
Comment by Dominik Riebeling (bluebrother) - Thursday, 22 October 2009, 22:14 GMT
This is a long known issue and already on the todo list: http://www.rockbox.org/wiki/RockboxUtilityDevelopment#Tasks (scroll to Milestone 2, second from the bottom). Furthermore, it's a theme issue and not a bug. For example, my linux setup doesn't show this issue. Ideally this should get fixed in Qt's theme.

Loading...