Rockbox

Tasklist

FS#10757 - 1 second gap after track skip

Attached to Project: Rockbox
Opened by Turke (obzen) - Wednesday, 04 November 2009, 00:53 GMT
Last edited by Rafaël Carré (funman) - Sunday, 08 November 2009, 23:29 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod Nano 2G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r23505

Rİght after skipping a track, a one second gap interrrupts the playing song.
This task depends upon

Closed by  Rafaël Carré (funman)
Sunday, 08 November 2009, 23:29 GMT
Reason for closing:  Not a Bug
Comment by Jeffrey Goode (Blue_Dude) - Saturday, 07 November 2009, 22:55 GMT
Can you list some details? Do you use crossfade? Which codec was active? Were you manually skipping or was it skipping to the next track automatically? Does it only occur once in a while? Can you duplicate it?

Please give as much detail as possible. Thanks.
Comment by Turke (obzen) - Saturday, 07 November 2009, 23:46 GMT
I don't use crossfade. I always use mp3s, so i guess it is the mp3 codec which is active. It happens when i skip manually to the next song. The song starts to play, but right after it started, a silent gap interrupts, for a very short time, let's say one second, then the song keeps on playing. That's it.
Comment by Jeffrey Goode (Blue_Dude) - Saturday, 07 November 2009, 23:59 GMT
OK, you manually skip to the next mp3 track (in the same directory?) and it plays a short blip of the new track, then cuts out for a second or so, then resumes? Does it actually pause playback and pick up again at the same place, or does it go silent for a second and you simply never hear that audio? Does it happen on every song, only on certain songs, or randomly?
Comment by Turke (obzen) - Sunday, 08 November 2009, 00:14 GMT
In the same directory, yes. And playback isn't paused. Just some silence goes into the playback.
Comment by Jeffrey Goode (Blue_Dude) - Sunday, 08 November 2009, 00:18 GMT
OK, so it's not a stutter, it just sounds like it was muted for a second? And it happens on every file?
Comment by Rafaël Carré (funman) - Sunday, 08 November 2009, 02:38 GMT
sounds like the time needed to buffer the next song

try waiting for 5 seconds or so and then press next, if the current song was fully buffered into RAM, the next one will have started to be buffered so track skipping should be immediate
Comment by Turke (obzen) - Sunday, 08 November 2009, 22:52 GMT
r23570.

I can not recreate this problem anymore. It seems to be gone.

Loading...