Rockbox

Tasklist

FS#10799 - Get revision number faster on subversion

Attached to Project: Rockbox
Opened by Seheon Ryu (cpu98) - Sunday, 22 November 2009, 00:58 GMT
Last edited by Jonathan Gordon (jdgordon) - Sunday, 22 November 2009, 18:22 GMT
Task Type Patches
Category Build environment
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Use gawk, grep instead of svnversion to determine revision number.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Sunday, 22 November 2009, 18:22 GMT
Reason for closing:  Not a Bug
Comment by Rosso Maltese (asettico) - Sunday, 22 November 2009, 09:55 GMT
You can also do something more efficient like these:

svn info "$@" | grep Revision | cut -d ' ' -f 2' (cut is very smaller than gawk)

svn info "$@" | gawk '$1=="Revision:" { print $2 }' (one pipe less)
Comment by Seheon Ryu (cpu98) - Sunday, 22 November 2009, 10:43 GMT
Others have no slowdown with their svnversion.
Seems my rig is out of order.

Loading...