Rockbox

Tasklist

FS#10816 - Simulator returns distorted PCM data

Attached to Project: Rockbox
Opened by Delyan Kratunov (archivator) - Thursday, 26 November 2009, 22:34 GMT
Last edited by Andree Buschmann (Buschel) - Friday, 19 November 2010, 23:43 GMT
Task Type Bugs
Category Simulator
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I started working on  FS#10065  again and immediately found a bug most likely in the sim. The attached screenshots/screendumps show obvious distortion in the data received from pcm_get_peak_buffer, while everything is fine on the actual target (iPod 5.5G, if that matters).

Last confirmed on r23717.
This task depends upon

Closed by  Andree Buschmann (Buschel)
Friday, 19 November 2010, 23:43 GMT
Reason for closing:  Works For Me
Additional comments about closing:  r28115 on sim for iPod 5.5G and nano 2G
Comment by Nils Wallménius (nls) - Friday, 04 December 2009, 20:32 GMT
Hi i tried looking into this but the patch in  FS#10065  doesn't build anymore, maybe you could post an updated patch to use when trying to track this down?
Comment by Delyan Kratunov (archivator) - Monday, 07 December 2009, 18:19 GMT
The attached patch is a snapshot of my current working tree. It's a bit larger than usual as it also includes the iPod Video graphics needed for the color and spectrogram modes.
Comment by Delyan Kratunov (archivator) - Wednesday, 28 April 2010, 16:00 GMT
Using r25695, I get the proper graph on device but the sim still returns incorrect data.
   dev.png (24.6 KiB)
   sim.png (147.3 KiB)
Comment by Andree Buschmann (Buschel) - Monday, 31 May 2010, 04:59 GMT
Hmm, at a first glance it looks like the spectrum that you show in the sim samples a signal with 1/32 of the targets sample rate.
Comment by Andree Buschmann (Buschel) - Wednesday, 17 November 2010, 19:55 GMT
The spectogram looks fine on simulation when using real music. Is this bug fxied or still occuring for you?

Loading...