Rockbox

Tasklist

FS#10828 - Prefetch abort every time I start a song.

Attached to Project: Rockbox
Opened by Benjamin Tan (tansrb) - Friday, 04 December 2009, 03:07 GMT
Last edited by Torne Wuff (torne) - Monday, 18 January 2010, 21:40 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Alright. So this is my first time using rockbox. I'm on an ipod 5.5G 60GB, and basically what happened yesterday was that whenever i started playing a playlist, after few seconds of the song, the player will play some static and show the phrase: "Prefetch abort at......" i've tried it many times however still nothing.

Help! i know rockbox is a very good software to run. however it's really impossible for me to actually do what with my current situation.

This task depends upon

Closed by  Torne Wuff (torne)
Monday, 18 January 2010, 21:40 GMT
Reason for closing:  Invalid
Additional comments about closing:  Guessing the original submitter probably was using the wrong build on a repaired player. RAM detection would be nice but is not a bug :)
Comment by Torne Wuff (torne) - Friday, 04 December 2009, 11:20 GMT
Are you certain it's actually a 5.5G with 64MB of ram? If playback *always* crashes immediately, this usually means you have the 64MB build installed on an ipod with only 32MB of ram - this can happen if the ipod has previously been repaired by replacing the logic board, as the logic board used as a replacement may have been from the 30GB model.

If the 32MB build doesn't work either, please mention the exact build you are using, and the string of numbers after "Prefetch abort at..." as well.
Comment by Benjamin Tan (tansrb) - Friday, 04 December 2009, 16:31 GMT
hmm... so you're saying i should try the rockbox 30GB format? alright will do and will get back to you. but im certain that it is of 60GB. not really certain about the rams as this is a second hand.

will try out your suggestion and get back to you about it.

will include the numbers if anything goes wrong too. thanks.
Comment by Torne Wuff (torne) - Friday, 04 December 2009, 16:34 GMT
The 30GB build is the build for players with 32MB of ram; the 60/80GB build is the build for players with 64MB of ram. The actual hard drive size doesn't matter, it's just that that's how much ram each model comes with when new. If it's second hand it's possible the previous owner had to have the logic board replaced, and may have replaced it with the board from a 30GB ipod - the Apple firmware still works if you do this, but Rockbox requires that you use the correct version for the amount of ram you have.

If using the 30GB build fixes the problem for you then this is almost certainly what has happened and thus there is no bug in rockbox :)
Comment by Alex Bennee (ajb) - Saturday, 05 December 2009, 21:24 GMT
Is it possible for Rockbox to detect the amount of RAM to give a better early warning than crashing?
Comment by Torne Wuff (torne) - Sunday, 06 December 2009, 22:06 GMT
Yes, it is. I am planning to do this at some point but have other things to do right now (in the long term it would be nice to move the plugin and codec buffers to the start of ram so that separate builds are not needed at all, in fact - then only the audio buffer size needs to be adjusted at boot time).

I am wondering if this did in fact fix the original poster's problem...

Loading...