Rockbox

Tasklist

FS#10835 - Warn on Playlist behaviour is possibly inconsitent.

Attached to Project: Rockbox
Opened by Alex Bennee (ajb) - Sunday, 06 December 2009, 20:43 GMT
Last edited by Jonathan Gordon (jdgordon) - Tuesday, 22 December 2009, 05:42 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If you have "Warn on Playlist Erase" enabled there are two paths that are possibly inconsistent.

1. Start a playlist
2. Play
3. Stop playback (or pause)
4. Attempt to start a new playlist
5. Get warning

Second path:

1. Start a playlist
2. Play
3. Reboot player (or Ctrl-C emulator and restart)
4. Attempt to start a new playlist
5. New playlist created straight away

However if you resume playback and then attempt step 4 you will get a warning.

While this behaviour in understandable (after all if the user cared about their lasy playlist they probably would resume) the behaviour is potentially inconsistent?
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Tuesday, 22 December 2009, 05:42 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  we dont remember the playlist dirty flag across boots, and doing so would be more effort than its worth.

Loading...