Rockbox

Tasklist

FS#10836 - Libfaad is very old

Attached to Project: Rockbox
Opened by Juliusz Chroboczek (jch) - Sunday, 06 December 2009, 21:00 GMT
Last edited by MichaelGiacomelli (saratoga) - Sunday, 06 December 2009, 21:01 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The version of libfaad in rockbox is from 2005. This is due to licensing issues, which have been resolved in version 2.6. From the Debian changelog:

* Update the copyright as new code includes a clarification of the license
text, which indicates that the entire work is under the GPLv2 (closes:
#419339).

While the changes in libfaad have not been enormous, there are a number of bug fixes, some of which may be about sound quality. It'd be great if libfaad 2.7 could be imported into Rockbox.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Sunday, 06 December 2009, 21:01 GMT
Reason for closing:  Not a Bug

Loading...