Rockbox

Tasklist

FS#10860 - Turning on dircache while sbs type theme is active causes data abort during reboot.

Attached to Project: Rockbox
Opened by Tomasz Kowalczyk (mitk) - Thursday, 17 December 2009, 11:59 GMT
Last edited by Jonathan Gordon (jdgordon) - Monday, 21 December 2009, 20:00 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority High
Reported Version Daily build (which?)
Due in Version Release 3.5
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Fuze v1/2gb, r24039.
Azure Whisper theme
Custom theme with sbs

Turning on dircache while using "sbs type" theme causes "Data abort at 30800968" after reboot. Rockbox don't start anymore without removing "dircache: on" option from config.cfg.
With themes not using sbs dircache can be enabled with no problem.
It is also possible to use "sbs type" themes after dircache is already on (dircache on, reboot, sbs theme on). But still when you turn off and then turn on dircache while sbs type theme is active you will get data abort.


Not sure about category for this bug.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Monday, 21 December 2009, 20:00 GMT
Reason for closing:  Out of Date
Additional comments about closing:  its not a bug, and if it was a bug, its been fixed.
Comment by Michael Chicoine (mc2739) - Thursday, 17 December 2009, 22:09 GMT
Tomasz,

Please try an updated build (r24055 or later). The "Data Abort" problem was due to changes in the sd driver. The changes that caused this problem have been reverted.
Comment by Tomasz Kowalczyk (mitk) - Friday, 18 December 2009, 11:53 GMT
Tried and findings are:
r:24065, 23977,23976,23928,23918,23904 - data abort
r: 23903, 23900 - OK, no problem
r23904 is "FS #10824 - viewport/statusbar API rework."

Fuze after format from OF with only rockbox and two sbs themes on internal card. No uSD card inserted. No media files at all.
Following test results I don't think that sd driver only caused this bug. It can be involved but only in connection with r23904.

Also I got "Panic, SD xfer read err: 0x8 Disk0" and found some broken files in .rockbox directory . It was Fuze with r24039 and it happened during reboot/disc scanning after dircache was activated. Theme was cabbiev2, internal card with lot of media files and 300 mb of free space + 16gb sdhc card with 12 gb of media files. (Un)fortunately I cannot reproduce this so that problem maybe was caused by sd driver but not for sure.
Comment by Michael Chicoine (mc2739) - Friday, 18 December 2009, 12:32 GMT
Tomasz,

Thanks for tracking this down. My comment above was based on information read in the Sansa AMS forum thread. The data abort with dircache on was mentioned there in a post about filename corruption. The filename corruption is what was fixed. The "Panic, SD xfer read err: 0x8 Disk0" was also mentioned in that thread and is likely to have been fixed by the sd driver changes.
Comment by Tomasz Kowalczyk (mitk) - Friday, 18 December 2009, 13:25 GMT
It's my point too. Panic on my Fuze probably happend during scanning corrupted file system and is more likely this way connected with 4 bit widebus commit.
"Data abort" definitely cannot be because r23976 and earlier are revisions with 4 bit widebus not implemented yet.
Comment by Jonathan Gordon (jdgordon) - Monday, 21 December 2009, 04:51 GMT
this apparently isnt a sbs bug... please edit the task or post a proper description so someone else can.
Comment by Bryan Childs (GodEater) - Monday, 21 December 2009, 08:40 GMT
I've also just tried to reproduce this on my iPod Video - and having a .sbs theme running at the same time as having dircache turned on works just fine for me.
Comment by Tomasz Kowalczyk (mitk) - Monday, 21 December 2009, 09:58 GMT
I tried this on Fuze with newer releases and for r24086 I got data abort
For r24087 and r24090 everything is OK. It's looking fixed by r24087.

Jonathan,
I never sad that this is bug in sbs. I sad that it appears on Fuze with releases from 23904 till 24086 when sbs type theme is enabled.
And now it is possible that this "nobody what bug" will return when other dev will add an functionality to rockbox. I sad possible :)
But now LOOKING LIKE you fix it in r29087. Please take decision about closing, not closing, editing, changing category ... whatever.
I have not enough rights on FS to do it.
Comment by Tomasz Kowalczyk (mitk) - Monday, 21 December 2009, 16:31 GMT
Bryan:
To reproduce this bug you must TURN ON dircache WHILE sbs theme is active. You also have to use one of releases I mentioned above.
Then after reboot (needed to activate dircache, right after splash "scanning disk" appears) on Fuze I've got data abort.
It is strange, I know this, but it happened. And may return in the future randomly when something will change in rockbox.
Comment by Bryan Childs (GodEater) - Monday, 21 December 2009, 17:54 GMT
So you're saying the bug, if bug it was - no longer happens?
Comment by Tomasz Kowalczyk (mitk) - Monday, 21 December 2009, 19:44 GMT
Please take a look at:
http://forums.rockbox.org/index.php?topic=14064.msg159515#msg159515


As I sad It happend with releases from 23904 till 24086. It arrived and dissapeared when some work was done with viewports and other stuff connected
with wps. Viewports are initialized during boot and dircache (if just turned on) is initialized during boot. It is only connection I know between dircache and wps/sbs.
I don't know well rockbox booting routines, memory management and threads management. I'm even not an programmer but imho there is a "something"
(for me a bug) which can randomly return when someone will make changes into rockbox code. I mean changes which will make some kind of impact on
initialization procedure.This is my point and it doesn't make difference if it be named bug or not.

Loading...