Rockbox

Tasklist

FS#10869 - Directory listing slow

Attached to Project: Rockbox
Opened by Paul Seropian (nospaulatu) - Saturday, 19 December 2009, 22:06 GMT
Last edited by Andree Buschmann (Buschel) - Friday, 21 October 2011, 12:23 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After plugging the iPod (5G / 5.5G 60gb Video) into the computer (Linux) and mounting it, the first ls command takes a long time to list directories. Older releases (the last one I believe was 3.2) were much faster. It seems as though the directory listing used to be cached before plugging it in, and now it is not.
This task depends upon

Closed by  Andree Buschmann (Buschel)
Friday, 21 October 2011, 12:23 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  As stated by author in his last comment.
Comment by Torne Wuff (torne) - Sunday, 20 December 2009, 00:11 GMT
I have also noticed this, but have no idea why...
Comment by Rosso Maltese (asettico) - Monday, 21 December 2009, 13:48 GMT
The same happens booting with the OF.
Could it depend on the media usage size?
Comment by Frank Gevaerts (fg) - Friday, 22 January 2010, 20:36 GMT
Rockbox doesn't keep the disk spinning, I can't remember if the OF does
Comment by Nils Wallménius (nls) - Tuesday, 15 February 2011, 21:26 GMT
Reopened this, i previously misread the second comment as a question. Anyway, that it happens with the OF indicates it's not a rockbox issue, although it doesn't explain why it would start suddenly. It would be helpful if you could retest an old version to confirm it doesn't do this.
Comment by Paul Seropian (nospaulatu) - Tuesday, 15 February 2011, 21:58 GMT
Thanks Nils for reopening the bug.

I'm having a difficult time finding the desired performance, however. I backed up and deleted my .rockbox directory, then installed and tested versions 3.0, 3.1 and 3.2 ... each of these versions boot into the OF when plugged in to USB, and all take some time to spin the disk to read the initial directory listing. I recall this being much faster at some point.

Perhaps it was a pre-3.0 daily build? Can I find those somewhere, or have they been deleted? It seems as though only the last 3 daily builds are kept online.

I'm very sorry, it seems I have wasted your time.

Perhaps we can rephrase this FS entry as a Feature Request for the Directory Cache feature of Rockbox is extended to USB directory listings?

Loading...