Rockbox

Tasklist

FS#10885 - Deleting the song you are playing locks up playback

Attached to Project: Rockbox
Opened by jasontaylor (jasontaylor) - Friday, 01 January 2010, 01:33 GMT
Last edited by Michael Chicoine (mc2739) - Friday, 01 January 2010, 15:25 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Deleting the song you are playing locks up playback.

How to reproduce. Download a song. Stick it on your mp3 player. Play it back. Long Press the select key. Press down as you scroll through a menu of "while playing" options. 2nd to the bottom is a delete feature. Hit it. Press select to delete the song. Now playback resumes playing the deleted song, since the delete routine is too ignorant to change the present song to null and mimic an escape key like function afterwards. If the mp3 file is small enough, it will fit in the buffer, so the codec won't get locked up in those cases. Tested on sansa clip should occur in all players. Occurs in present builds.


Proposed solution to fix bug: if you delete the present file being played mimic an escape function and/or start playing the next song afterwards. Few lines of code need to get injected into the delete while playing routine.

This task depends upon

Closed by  Michael Chicoine (mc2739)
Friday, 01 January 2010, 15:25 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of FS#10874
Comment by jasontaylor (jasontaylor) - Friday, 01 January 2010, 02:01 GMT Comment by jasontaylor (jasontaylor) - Friday, 01 January 2010, 14:27 GMT

Loading...