Rockbox

Tasklist

FS#10917 - MP3 encoder is not working

Attached to Project: Rockbox
Opened by William (lee321987) - Sunday, 17 January 2010, 05:22 GMT
Last edited by Nils Wallménius (nls) - Monday, 18 January 2010, 07:47 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

(build: e200v1 - r24254)

Recording into MP3 format results in a file with no sound (actually has a very strange noise _pattern_, but you have to amplifiy alot to hear it).

Example MP3:
This task depends upon

Closed by  Nils Wallménius (nls)
Monday, 18 January 2010, 07:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in r24271
Comment by Michael Chicoine (mc2739) - Sunday, 17 January 2010, 19:15 GMT
tested with r24262 on e280v1

1) MP3 recording works fine on my e200 both from the mic and fm radio.

2) This sounds like a duplicate of  FS#10678 
Comment by Nils Wallménius (nls) - Sunday, 17 January 2010, 21:56 GMT
Please note that the mp3 encoder plugin and the mp3 encoding codec are two entirely seperate peices of code.
AFAIU this is using the encoding codec while recording and fs#10678 is with the plugin.

William, could you please provide your recording settings and try if it works with older versions of rockbox and if other recording formats are affeted?
Comment by William (lee321987) - Sunday, 17 January 2010, 22:41 GMT
Michael Chicoines' comment made sense with my original post, but I had an admin edit my original post because it mentioned the same bug that MC linked to.

Other formats record correctly.

My settings:
bitrate: 32kbps
source: mic and FM -- neither works
channels: mono
mono mode: mono Left + Right

I was bisecting old versions, but seem to have installed a version that needs an older bootloader, so now my player won't boot, and I have to go back through how to fix this,

Comment by William (lee321987) - Monday, 18 January 2010, 00:50 GMT
Through bisecting I found out the commit that caused this:
http://svn.rockbox.org/viewvc.cgi?view=rev;revision=23784
Comment by William (lee321987) - Monday, 18 January 2010, 01:54 GMT
Mono Modes:
Mono Left + Right ------ does not work
Mono Left ---------------- WORKS
Mon Right ---------------- does not work
Comment by Nils Wallménius (nls) - Monday, 18 January 2010, 03:03 GMT
I committed a fix to l+r, it was only using one channel, however it seems one channel is lost too, so this looks like another bug, you do get sound in both channels when recording in stereo?

edit: committed another fix that might fix the other problem

edit: comitted a fix that i am fairly confident should work now
Comment by William (lee321987) - Monday, 18 January 2010, 03:23 GMT
Stereo ======= good
Mono L+R ==== strange distortion
Mono R ====== strange distortion (louder)
Mono L ====== good

All modes play back in both ears.
Comment by William (lee321987) - Monday, 18 January 2010, 07:03 GMT
Looks good. Thank you Nils.

Loading...