Rockbox

Tasklist

FS#10964 - SUPERDOM game, I love it, but here are some bugs

Attached to Project: Rockbox
Opened by Ed (ED-209) - Thursday, 04 February 2010, 04:20 GMT
Last edited by Teruaki Kawashima (teru) - Tuesday, 06 July 2010, 14:39 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

the strategy game SUPERDOM is totally addictive and I probably play it way too much, but has some bugs which make playing it a bit less enjoyable.

when choosing the human/computer starting factories/farms you can only choose 1/1 2/2 3/3 of each. any other combination (like 2/3 for each, or 1/4 or 3/2 etc) comes up with seemingly random results... the player always ends up with more of something.. it seems you can't let the game give you less farms/factories than the computer has. if you choose 4 of each for each player it just doesn't work, it assigns the wrong numbers of everything for every player.

also, if there can be some improvements made? when viewing a square it would be good to see how many men of your own on that particular square, and when buying items it would be good to display how much money you have left instead of having to remember it from when you check your inventory. it would also be good if it had a max out function when you're buying items (when you type out how many men/tanks/planes you want to buy you have to remember hwo much funds you have, and then remember what you're buying, if it could max out the number of men at your credits limit no matter how high the number is you type in... if you get what I mean)

anyway the last suggestions would be cool but the first bugs make interesting combinations impossible (1 factory and 3 farms for each... or just any variant from x/x y/y number of factories and farms for human and computer)

thanks again for rockbox and this game, if I can help in any way let me know
This task depends upon

Closed by  Teruaki Kawashima (teru)
Tuesday, 06 July 2010, 14:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  I can't reproduce this. if there are still bugs, please create a new task.
Comment by Teruaki Kawashima (teru) - Thursday, 04 February 2010, 13:15 GMT
I fixed one issue in superdom. but i couldn't reproduce what you mentioned using gigabeat x.
if i set "computer starting factories" to 4 and start game, there is always 4 factories on computer's territory.
Could you describe the details and chek if it happens on the simlator?

Loading...