Rockbox

Tasklist

FS#11034 - 3G bootup and default contrast fix

Attached to Project: Rockbox
Opened by Andrew Engelbrecht (sudoman) - Thursday, 18 February 2010, 01:29 GMT
Last edited by MichaelGiacomelli (saratoga) - Thursday, 18 February 2010, 04:22 GMT
Task Type Patches
Category Configuration
Status Closed
Assigned To No-one
Operating System iPod 3G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

normally, the ipod boots up with a dark screen half-way through. it stays dark once the firmware is loaded unless a good contrast setting is chosen in config.cfg.

i noticed that there seemed to be two places that defined a default contrast setting. the first is:
firmware/export/config/ipod3g.h

the setting there was for 40. so i made a patch for the other file redefining the contrast from 55 to 40 for the 3G. i've tried setting my ipod to 40 contrast and the result looks good.

i haven't been able to test this because i'm having difficulty setting up the build environment.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Thursday, 18 February 2010, 04:22 GMT
Reason for closing:  Accepted
Additional comments about closing:  Accepted in r24742. Will close  FS#11006  once confirmed fixed.
Comment by Andrew Engelbrecht (sudoman) - Thursday, 18 February 2010, 01:43 GMT
this is hopefully a fix for: http://www.rockbox.org/tracker/task/11006

Loading...