Rockbox

Tasklist

FS#11063 - ipod turns itself on for no reason, seems to think wakeup alarm is set?

Attached to Project: Rockbox
Opened by Dave Hooper (stripwax) - Saturday, 27 February 2010, 10:03 GMT
Last edited by Torne Wuff (torne) - Tuesday, 04 May 2010, 22:28 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

No idea if this applies to other players. It only seemed to start happening for me at some point after the ipod video shutdown patch went into trunk (the one that uses the OF to shutdown).
Sometimes, when I turn my ipod on, I find it is in the OF, even though I shutdown from rockbox. Say, it's a day since I shutdown rockbox, I turn my ipod on and I get the apple logo quickly and then the OF. i.e. a "hibernate" wakeup rather than full OF boot.

What appears to be happening is this: rockbox wakeup alarm must be turning itself on (with a random time, presumably, since I didn't set one); this coupled with the fact I leave my hold switch on means at the wakeup time the OF boots; then (at some point before I turn on my ipod) the OF has already hibernated; so that when I turn it on it's a "quick" OF boot.

It seems to be more reproducible if I leave the ipod plugged into usb for a long period of time, but that reeks of coincidence to me.

One additional annoyance is that, from rockbox, I can't even *see* if the wakeup alarm is enabled or disabled - I can manually set it or cancel it, but I cannot determine if it is set or unset without changing its state to set or unset, as far as I can tell. This means I cannot actually tell if rockbox is somehow re-enabling my wakeup alarm after I manually unset it, or something else.

This task depends upon

Closed by  Torne Wuff (torne)
Tuesday, 04 May 2010, 22:28 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Now that  FS#11149  has been committed in r25772 there is no reason why this should happen any more.
Comment by Dave Hooper (stripwax) - Saturday, 27 February 2010, 10:24 GMT
FS#10830 might be related.
Comment by Torne Wuff (torne) - Saturday, 27 February 2010, 10:58 GMT
This is supposed to be fixed... the shutdown patch checks if a Rockbox alarm is set at shutdown time, and if not, it calls rtc_enable_alarm(false) to make sure the power controller is set not to wake up. Several people had this problem while testing the original patch, and this code was added to fix this, after which none of the people testing it had this problem any more. :(

I'm disassembling the bootloader at present to work out a better way to solve the shutdown issue...
Comment by Dave Hooper (stripwax) - Wednesday, 14 April 2010, 08:43 GMT
 FS#11149  appears to fix perfectly for me.

Loading...