Rockbox

Tasklist

FS#11091 - Plugging into USB when in "View Battery"

Attached to Project: Rockbox
Opened by Alex (Darkknight512) - Thursday, 11 March 2010, 02:14 GMT
Last edited by amaury pouly (pamaury) - Monday, 03 May 2010, 11:10 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System iPod Nano 2G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If I plugin a USB cable into the Nano2G while in View Battery the DAP starts charging as if I held Menu when I plugged it in. If I were to plug the DAP in while in View Battery and I exit View Battery the player refuses to play audio when you try to go into Now Playing resulting in a crash and Menu+Select reboot.
This task depends upon

Closed by  amaury pouly (pamaury)
Monday, 03 May 2010, 11:10 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  The Debug Menu is mainly for developers and there is not support for it. This "bug" has no simple solution and thus we don't want to add extra code to fix it.
However, the patch in FS#11101 *might* *help* if you *really* want to *do* something about it (it's not a miracle solution however).
Comment by Michael Sparmann (TheSeven) - Friday, 12 March 2010, 20:05 GMT
Ah, nice catch! I saw that once, but couldn't reproduce it.
I think the part that it doesn't enter USB mode when plugged in while in the view battery screen is intentional (to diagnose charging), but the latter clearly isn't.
Comment by Alex (Darkknight512) - Friday, 12 March 2010, 21:38 GMT
Umm, one slightly off topic question, I think the battery estimated time should be calibrated. I did post a battery bench a while back. It currently say about 4800 minutes, it should be 720 - 780
Comment by Michael Sparmann (TheSeven) - Friday, 12 March 2010, 22:10 GMT
I get more than 1000 minutes when playing high-bitrate VBR MP3, which is quite some work for the processor, and my battery is three and a half years old and heavily used.
The battery calibration was actually done. (So the percentage gauge should be accurate, even while charging.) What hasn't been done yet is analyzing how much current the iPod will take in which situation, to estimate that correctly. I consider the whole framework for that just broken, as we have can actually measure the battery current on that device to get even better estimates without the need for calibration. (For charging, this even worse, everthing is adjusted for NiMH batteries in some certain Archos devices.) One day I'll probably come up with some better approach to this, but currently I'm hesitating to calibrate that old stuff.
Comment by amaury pouly (pamaury) - Monday, 03 May 2010, 09:50 GMT
This is not a bug. In fact, if you plug while in battery view, the usb thread will ask all threads to acknowledge the usb insertion.
All will do except one because you are in battery view. Consequently, it will not play audio because some crucial threads are waiting for ubs removal (buffering thread for example).
I guess the behaviour for battery is intentional but nothing can be done easily about the second part.

This is not specific to Nano2G.

Loading...