Rockbox

Tasklist

FS#11117 - PDF Manual: WPS Tag tables - first tag entry is shifted right one character

Attached to Project: Rockbox
Opened by Michael Chicoine (mc2739) - Wednesday, 17 March 2010, 03:12 GMT
Last edited by Alexander Levin (fml2) - Saturday, 27 March 2010, 15:46 GMT
Task Type Bugs
Category Manual
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In the PDF Manuals, Appendix B, WPS Tags the first WPS tag in each of the tables is shifted to the right by one character.

The 3.5 release manuals look correct.
This task depends upon

Closed by  Alexander Levin (fml2)
Saturday, 27 March 2010, 15:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in r25307 and r25349
Comment by Alexander Levin (fml2) - Monday, 22 March 2010, 13:14 GMT
This is probably caused by the changes made in r25065. The changes are not quite correct. In the file "manual/appendix/wps_tags.tex" all occurrences of "\begin{tagmap}{}{}" should be replaced with "\begin{tagmap}". I can't try it now but I'm quite confident that this would fix the bug. Could you please try it and, if it does help, commit the patch?
Comment by Michael Chicoine (mc2739) - Monday, 22 March 2010, 23:32 GMT
I replaced "\begin{tagmap}{}{}" with "\begin{tagmap}" as you suggested and it does correct all of the tables except for the "Viewports" table. In this table, the %V seems to be shifted two positions to the right. After changing "\begin{tagmap}", the line is still shifted to the right. If you know what is causing this shift, I can fix it at the same time.
Comment by Michael Chicoine (mc2739) - Tuesday, 23 March 2010, 00:54 GMT
It appears that the %V shift is caused by the two \nopt sections. If I remove those two sections, the %V line is lined up properly (E200 pdf manual). With either section restored, the line is shifted.
Comment by Alexander Levin (fml2) - Tuesday, 23 March 2010, 06:55 GMT
The line "\nopt{lcd_non-mono}{~%" seems suspicious to me. What happens if you remove the '~'? It should be removed anyway since it produces a space which is not needed here.

Did this place look OK before r25065? I ask because I think that the changes made in r25065 have nothing to do with this particular problem.
Comment by Michael Chicoine (mc2739) - Tuesday, 23 March 2010, 11:29 GMT
Removing the "~" did not help.

This did not look correct even before r25065. Both the 3.4 and 3.5 release manuals have the %V shifted.
Comment by Alexander Levin (fml2) - Tuesday, 23 March 2010, 11:53 GMT
Then I think we should commit the patch that fixes all other places, and also remove the '~'. Fixing the %V will be done in another patch. I won't be able to do it before the weekend, so if you have SVN access you can do it.
Comment by Michael Chicoine (mc2739) - Tuesday, 23 March 2010, 12:04 GMT
Committed r25307 to fix all other places and remove '~'.
Comment by Alexander Levin (fml2) - Saturday, 27 March 2010, 13:15 GMT
A fix for the rest has been committed in r25349.

Loading...