Rockbox

Tasklist

FS#11163 - rbutil: Proxy configuration doesn't work

Attached to Project: Rockbox
Opened by Tomer Shalev (tomers) - Thursday, 01 April 2010, 06:02 GMT
Last edited by Dominik Riebeling (bluebrother) - Thursday, 03 June 2010, 15:43 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Rbutil SVN
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Rockbox Utility version r25247
http://www.alice-dsl.net/dominik.riebeling/rockbox/rbutil/RockboxUtility-r25247.zip

I am not able to configure the utility to work under proxy. My network setup in my office blocks Internet access unless it passes through a proxy. I configured the utility's Proxy configuration either with manual proxy settings (Proxy host and port) or with 'Use system values'. Neither of them worked.

I managed to use some older version of the utility (I don't remember which), so I suspect that's a bug. Can someone please verify this?
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Thursday, 03 June 2010, 15:43 GMT
Reason for closing:  Fixed
Comment by Dominik Riebeling (bluebrother) - Thursday, 01 April 2010, 16:45 GMT
Please verify the network settings in Internet Explorer. Are they correct? If it's using an autoconfiguration entry it won't work as that is not supported -- "System Values" takes the *static* values set for Internet Explorer (the value "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings" from the registry)
Comment by Dmitry Gromov (dgcom) - Wednesday, 02 June 2010, 22:14 GMT
Was just about to file tha same bug report.
I can also verify that Rockbox Utility http proxy support starting with version 1.2.4 is broken.
I have 1.2.3 which works perfectly well, but any newer one complains about accessing download.rockbox.org right on start.
Some detailed analysis shows that Utility ignores proxy settings - with proxy configured it first tries to directly resolve download.rockbox.org.
If name lookup fails, Network configuration error shows up immediately.
If name lookup succeeds, no error is shown, but none of the normal functionality is available in the program - all http requests to download.rockbox.org just timing out.

I'm attaching zip file with 2 logs (Help-Troubleshoot-System Trace) saved from versions 1.2.3 (working) and 1.2.5 (broken) one after another.

Really sad that this issue is there for such long time - I see complains from people in forums and no fix :(
Comment by Dominik Riebeling (bluebrother) - Thursday, 03 June 2010, 06:13 GMT
Really sad to see almost no people complaining about this issue and even less being helpful in finding out what's going on or replying to questions in the tracker. This is the first report that contains actually useful information (the logs).

From looking at the source this seems to be caused by the proxy being set too late, not it not working at all. It should work after you open the configuration dialog, then closing it again with Ok (*not* with Cancel!). During the internal configuration update the proxy configuration is set, but this isn't done before retrieving the configuration from the server. So as a workaround it should be possible to go to the configuration dialog first.

Loading...