Rockbox

Tasklist

FS#11182 - On load, configured player is not shown if it is from the disabled targets list

Attached to Project: Rockbox
Opened by Tomer Shalev (tomers) - Wednesday, 07 April 2010, 05:09 GMT
Last edited by Dominik Riebeling (bluebrother) - Wednesday, 07 April 2010, 19:20 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Rbutil SVN
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

To reproduce:
1. Delete rbutil configuration file
2. Load rbutil
3. Check 'Show disabled targets'
4. Select 'Cowon D2' audio player
5. Select arbitrary drive as the device filesystem (no need to have the actual device)
6. Alternatively, select a language that is different from the currently used language
7. Close the configuration dialog box and verify the selected DAP and mount point are set according to what you have just configured
8. Restart the application

Expected behavior: The player, mount point, and optionally the interface language are set exactly as you have configured previously.

Actual behavior: There's an error message: 'device / mountpoint unknown or invalid'.

Note that after configuring the application, when opening the dialog box once again the checkbox 'Show disabled targets' does not preserve its last state (its value is probably not save as an application setting). This force the user to re-select the audio player on each entry to the configuration dialog box, and is quite annoying.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Wednesday, 07 April 2010, 19:20 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  as discussed on IRC.
Comment by Dominik Riebeling (bluebrother) - Wednesday, 07 April 2010, 17:03 GMT
I don't see a problem here and it works fine for me.

Not saving the "show disabled targets" option is intentional, and I don't think it would be a good idea to change that. If you use a disabled target and restart Rockbox Utility the device selection is preserved as expected, hence there is no need to configure Rockbox Utility again. Remember, the "disabled targets" aren't intended for use by end users!

We could also remove the "show disabled targets" option again, that would remove the option to use those targets at all (except if you compile yourself) ...

Also, please do always post the version of Rockbox Utility used.

Loading...