Rockbox

Tasklist

FS#11190 - Text Viewer shows no Text when skipping to last page

Attached to Project: Rockbox
Opened by Hunter Ragnarok (G4Oblivion) - Thursday, 08 April 2010, 02:01 GMT
Last edited by Tomer Shalev (tomers) - Monday, 12 April 2010, 19:29 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To Tomer Shalev (tomers)
Operating System iPod Nano 2G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I skip to the last page of a Text file using the Text Viewer the page turns black and my player runs slow. ( I left it loading for over 2min. still did not show the text )
It shows the current page number I'm on but doesn't show text.
When I try to quit the Text Viewer my player freezes and I have the reboot using Main menu + Select.
After the iPod is restarted it starts on the page I left off at and shows the text.

This started happening sometime after Tomer Shalev started updating with the Text Viewer. r25508+

I think this happens for all players, I'm not sure I only have one Rockbox compatible player.

Using iPod Nano 2G
Text file is a little over 700kb
Text file has a little over 5000 pages (Rockbox Text Viewer pages)
Using latest daily build (r25527)

If you need more information just ask. This is my first time reporting a bug.
This task depends upon

Closed by  Tomer Shalev (tomers)
Monday, 12 April 2010, 19:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in r25612. Reopen if issue reoccurs.
Comment by Tomer Shalev (tomers) - Thursday, 08 April 2010, 04:41 GMT
Thanks for reporting. Can you please attach a text file which causes this issue?
Does it happens with any text file, or only with large files?
I'll try to reproduce this on iPod Nano 2G simulator, and hopefully fix that.
Comment by Hunter Ragnarok (G4Oblivion) - Thursday, 08 April 2010, 06:15 GMT
I skipped to the end of a 2000 page text file and it loaded fine. I think it only goes blank with larger ones.
I tried to get it to freeze again but I couldn't. I think it freezes because its trying to save my place and it just doesn't have enough *power* to do it. (not sure what memory mp3's use.)
I tried it on another big file and the same thing happened.

It seems like my iPod is working fine now though. I used it on a couple other files and it skipped pretty fast to the end.
Altough it seems to be gone it doesn't change the fact that it happened. I believe it will do the same thing again once I update it and it has to load everything again.
It did not do this before the updates. Thank you very much though for updating it. This isn't a very big problem for me.

The text file is one of my e-books I converted to a text file.
Comment by Tomer Shalev (tomers) - Thursday, 08 April 2010, 06:36 GMT
> I skipped to the end of a 2000 page text file and it loaded fine. I think it only goes blank with larger ones.

I didn't dive into it, but it seems that going BACK one page is implemented in an highly inefficient manner. I think it re-reads the entire content from the start, which could cause the issues you have reported after you press the button which gets you to the last page, and then press the button to go one page up.
Comment by Hayden Pearce (St.) - Sunday, 11 April 2010, 03:08 GMT
Thought I'd add my two cents as I ran into this on my Nano 1/2gens recently...

The file I can reproduce this with is "config.cfg", which is nowhere near 2,000 lines at all...
I also don't get any hard-lock behaviour as reported by Hunter Ragnarok (G4Oblivion) which is a little odd, as it's the same target (in one case at least).
All that happens to me is that the very instant the last page of the file is viewed, all the text dissappears. The screen is still illuminated, I can still scroll up/down through the (now blank) file, only there is no text anymore.
Not sure when this popped up, but it's definitely reproducable...and *very* annoying :/


St.

Loading...