Rockbox

Tasklist

FS#11201 - Viewer: Bookmarks data gets deleted

Attached to Project: Rockbox
Opened by Tomer Shalev (tomers) - Wednesday, 14 April 2010, 11:02 GMT
Last edited by Yoshihisa Uchida (Uchida) - Sunday, 06 June 2010, 10:11 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

To reproduce:
1. Create several bookmarks (lines gets highlighted)
2. Go to line 1 of the text file (browse up all the way)
3. Change alignment direction

Expected behavior:
Bookmarks are preserved; Bookmarked lines are still highlighted.

Observed behavior:
All bookmarks now point to the same line (line 1 at page 1). That line is highlighted.

Notes:
- The bug does not occurs for any line other than the first line in the text file is browsed to (step 2).

- The bug is caused by wrong calculation in calc_page()
This task depends upon

Closed by  Yoshihisa Uchida (Uchida)
Sunday, 06 June 2010, 10:11 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  this is the design.
Comment by Yoshihisa Uchida (Uchida) - Wednesday, 14 April 2010, 12:27 GMT
It is thought that this is not problem but correct movement.
To become such movement, I create the logic.

Reason
Because the text viewer moves by each line, any bookmark is specified by each line.
When the text viewer moves the bookmark to the first page, moreover, when returning it to the movement by each line, it cannot be returned to original position.

"page" is a unit of the appearance, and it changes under various conditions.
for example,
all bookmarks move to the first line. => the settings change (page and the position of bookmarks change) => all bookmarks move to the first line =>...

all bookmarks move from the original place into quite another place.
This is a problem.

Loading...