FS#11230 - Resume function does not work correctly after Idle Poweroff

Attached to Project: Rockbox
Opened by Michael Bauminger (mikebomb) - Friday, 30 April 2010, 09:24 GMT
Last edited by Torne Wuff (torne) - Friday, 30 April 2010, 12:33 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


This is actually release version 3.5.1.

Expected behavior: When starting the player after an Idle Poweroff, "Resume Playback" should resume where you left off, in the same playlist, on the same track, at the same place.

Actual behavior: Resume, if available, plays the last place you manually bookmarked, stopped, or turned off the player.

Steps to duplicate:

1. Set Idle Poweroff to some value such as 1 minute, Bookmarking > Bookmark On Stop to "Ask - Recent Only", Bookmarking > Load Last Bookmark to "Ask", and Bookmarking > Maintain a list of Recent Bookmarks to "Unique Only".
2. Play something, pause it, stop the playback, and manually turn off the player.
3. Turn the player on and use the Playlist Catalog to play a different saved playlist.
4. Pause the playback and allow the unit to power off.

When you start the player again, Resume will pick up where you manually stopped the player and turned it off, not where it automatically powered off.
This task depends upon

Closed by  Torne Wuff (torne)
Friday, 30 April 2010, 12:33 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Already fixed in r25376
Comment by Torne Wuff (torne) - Friday, 30 April 2010, 12:33 GMT
This is because bookmark on stop is set to ask. This breaks idle poweroff in 3.5.1, because it just sits there waiting for you to say whether you want a bookmark or not, and it ends up shutting down the player after a timeout without saving settings such as the resume position.

I have already fixed this in svn revision 25376 (I noticed this a couple of weeks ago). Either upgrade to the current build, or set bookmark on stop to something other than "ask".