Rockbox

Tasklist

FS#11280 - Cygwin and mingw sims don't respond to keypresses

Attached to Project: Rockbox
Opened by Frank Gevaerts (fg) - Sunday, 16 May 2010, 17:45 GMT
Last edited by Thomas Martitz (kugel.) - Monday, 17 May 2010, 17:20 GMT
Task Type Bugs
Category Simulator
Status Closed
Assigned To Thomas Martitz (kugel.)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Simulators built for cygwin or mingw don't respond to button presses anymore, presumably since r26065 (where SDL_WaitEvent() was replaced with SDL_PollEvent(), along with some threading changes).

This is reproducible using wine.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Monday, 17 May 2010, 17:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  r26113
Comment by Thomas Martitz (kugel.) - Sunday, 16 May 2010, 23:32 GMT
http://lists.libsdl.org/pipermail/sdl-libsdl.org/2004-August/045410.html seems to be the same problem.

It appears that on windows event polling needs to be done in the main thread. In fact, hacking a SDL_PollEvent() call into main.c makes me getting at least an event. I'll have a more deeply look later.

Loading...