Rockbox

Tasklist

FS#11362 - Voice mis-match after upgrading to RB 3.6.

Attached to Project: Rockbox
Opened by Peter D. (PeterD) - Sunday, 06 June 2010, 10:51 GMT
Last edited by Dominik Riebeling (bluebrother) - Friday, 11 June 2010, 17:14 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Release 3.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After upgrading to 3.6 the audio interface no longer matched the menu structure - the wrong items were read out. In an attempt to fix the problem I reinstalled the voices, and then did a complete installation. All without success.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Friday, 11 June 2010, 17:14 GMT
Reason for closing:  Fixed
Comment by Dominik Riebeling (bluebrother) - Sunday, 06 June 2010, 14:48 GMT
This sounds like a mismatch between voice files and build caused by the lang cleanup done this weekend. How did you install the voice file? Rockbox Utility can only install voice files for current builds. You need to either install a current build or install the voice file for 3.6 manually.
Comment by Peter D. (PeterD) - Monday, 07 June 2010, 07:34 GMT
The Rockbox Utility was used throughout.

I *think* that the sequence was;
install 3.6, then noticed the voicing was wrong,
install voice, no joy,
did a complete install of 3.6, still wrong,
opened this bug report,
did a current install.

It seems to be working now.

The real bug seem to be that matching sets of voice files are not kept and installed by the Rockbox Utility. Three days after an official release it was installing incompatible sets.

Should this bug report be closed and a new one opened?
Comment by Dominik Riebeling (bluebrother) - Monday, 07 June 2010, 16:55 GMT
Ok, then this is the issue I suspected. It is already fixed in svn, so no need for a new report. If you want to try it you can use svn binaries of Rockbox Utility available at http://tinyurl.com/rbutil-dev (note that the Linux binary available at that URL is too old). There is a similar issue for fonts which will get fixed shortly (this issue doesn't have any negative effect right now as there was no change to the fonts package).

As the original issue is fixed I'll close this report in a couple of days. Hopefully a new version of Rockbox Utility will be available soon.

Loading...