Rockbox

Tasklist

FS#11386 - Text Viewer: Bookmark problem

Attached to Project: Rockbox
Opened by Hunter Ragnarok (G4Oblivion) - Wednesday, 09 June 2010, 06:05 GMT
Last edited by Jonathan Gordon (jdgordon) - Thursday, 10 June 2010, 15:35 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To Yoshihisa Uchida (Uchida)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I make a bookmark, scroll a couple pages and go to viewer options > Select bookmark
It doesn't work. I get one of these three things: Start from current page, Start from first page or just nothing at all.
Select bookmarks will not jump to any of my bookmarks.
This has been happening since the new text viewer was committed. I am using the latest daily build.

To reproduce:

1) Create a bookmark
2) Scroll down or up a few pages
3) Go to Viewer options > Select bookmark
4) Try to select the bookmark you just created. It will not work.

I have tried getting it to work multiple times in different ways. It will not jump to any of my bookmarks.
I figured this would be fixed by now but after seeing how it took you 2 days + to fix the broken text viewer, I realized I should report this now.

Note: I would like my "Skip to last page" back. I don't care if its in viewer options.
Just think about the people with text files that have 2k+ pages.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Thursday, 10 June 2010, 15:35 GMT
Reason for closing:  Fixed
Comment by Yoshihisa Uchida (Uchida) - Wednesday, 09 June 2010, 12:08 GMT
this problem confirmed.
I am investigating the cause of this problem, and wait for a while.
Comment by Yoshihisa Uchida (Uchida) - Thursday, 10 June 2010, 10:59 GMT
this problem is fixed by r26738. please confirm it.
Comment by Hunter Ragnarok (G4Oblivion) - Thursday, 10 June 2010, 15:28 GMT
The problem has been fixed. Thank you.

Loading...