Rockbox

Tasklist

FS#11419 - flac problem clipv2

Attached to Project: Rockbox
Opened by whocares (Lutzero) - Saturday, 19 June 2010, 13:52 GMT
Last edited by Rafaël Carré (funman) - Tuesday, 22 June 2010, 20:04 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r26955-100619
Sansa Clip v2

While playing tracks (flac) it skips to next song after around 30 seconds.
This task depends upon

Closed by  Rafaël Carré (funman)
Tuesday, 22 June 2010, 20:04 GMT
Reason for closing:  Fixed
Comment by MichaelGiacomelli (saratoga) - Saturday, 19 June 2010, 22:07 GMT
Happens on APE files too. Codec failure and then skips to the next track, or sometimes just gives static, presumably because the codec state is screwed up.
Comment by Lennert (Lennert) - Sunday, 20 June 2010, 15:00 GMT
This also happens on my Sansa Clip+ (r26992-100620), every time between 43s and 47s, with ~1060kbps FLAC files. Lower bitrate FLAC files take a little longer before skipping to the next track (an 800kbps FLAC after 55s, 743kbps after 1:05). The same files always skip to next track at the same time.

I know this problem is introduced recently as I play FLAC files often, so I tried ROLO to revert to older daily builds. r26978 had the same issue, but r26946-100619 didn't have this issue, here the files played normally.

So for Clip+, this has been introduced in a revision after r26946.

Also, in r26979 there's mentioned that this might solve playback problems for lossless files on Clipv2. This had no effect on my Clip+, as r26992 still skips to next track.
Comment by whocares (Lutzero) - Sunday, 20 June 2010, 18:56 GMT
Problem seems fixed now, i only test flac, but it seems to work with r26997 (todays build). No more skipping after around half a minute playing.
Thanks, i was getting pretty sick of the standard sansa firmware already ;)
Comment by Andree Buschmann (Buschel) - Sunday, 20 June 2010, 18:57 GMT
Summarizing the posts above:
1) introcuded between r26947 -- r26955
2) reproducible on clipv2 and clip+
3) duration until codec failure seems to depend on buffered data (after ~6000KB for each given example)
=> looks like r26953 and r26954 are hot candidates.
Comment by whocares (Lutzero) - Sunday, 20 June 2010, 18:58 GMT
wow thats quick :p
Comment by whocares (Lutzero) - Sunday, 20 June 2010, 19:12 GMT
Problem seems fixed now, i only test flac, but it seems to work with r26997 (todays build). No more skipping after around half a minute playing.
Thanks, i was getting pretty sick of the standard sansa firmware already ;) , assuming you typed at the same time i did and didn't read my post.
Comment by Andree Buschmann (Buschel) - Sunday, 20 June 2010, 20:08 GMT
Yes, we typed at the same time. And yes, I read your comment. Nevertheless I wonder why this should be fixed, there has been no change since r26992 (which you stated shows the failure) and now (r26997) that should have had any effect.
Comment by Lennert (Lennert) - Sunday, 20 June 2010, 20:09 GMT
Do FLAC files now play completely to the end on your Clipv2 with r26997?

Because on my Clip+ this revision still skips to the next track, no change here.
The FLAC files I tested in my first post still skip at the same time.

If I'm reading right, r26997 also seems to change something for e200v2, not for Clips.
Comment by Andree Buschmann (Buschel) - Sunday, 20 June 2010, 20:24 GMT
Lennert, can you build rockbox or are you using downloaded builds? If you can build it -> can you check whether r26953/r26954 introduced the issue?
Comment by Lennert (Lennert) - Sunday, 20 June 2010, 21:54 GMT
Sorry, I'm using downloaded builds...
Comment by whocares (Lutzero) - Monday, 21 June 2010, 05:01 GMT
Sorry, my bad, the problem still exists with r26997, r27003 still has the problem too.
Im using downloaded builds for your information.
Comment by Lennert (Lennert) - Monday, 21 June 2010, 12:12 GMT
OK, I built Rockbox from SVN and used ROLO to test a few revisions:

v26952: No problems, FLACs play to the end.
v26953: First FLAC I played made my player crash (WPS showed track name, time 0:00 and ?kbit, total freeze), I had to perform a hard reset.
Also with MP3's this revision crashes (one file had a data abort at 3000AEE8, another file had a prefetch abort at E5D43014) and reboots back to my default rockbox after I press home.
This seems to give even more problems on my Clip+...
v26954: Has the issue as above, FLAC files skip to next track

Just let me know if I can test something else.
Comment by Rafaël Carré (funman) - Monday, 21 June 2010, 18:05 GMT
=> looks like r26953 and r26954 are hot candidates.

Indeed they are the faulty commits.

Not sure if I should revert them yet, because I don't see what could be wrong with these commits, unless:

- *_dcache_range() are buggy (I've looked at them several times but more eyes are welcome)
- STORAGE_WANTS_ALIGN is buggy (TheSeven is looking at this code atm so I would like to wait if he finds bugs)
- read/write buffer is accessed before sd_transfer_sectors() returns, which would be pretty bad
Comment by Andree Buschmann (Buschel) - Tuesday, 22 June 2010, 05:21 GMT
I would revert the code changes to have a working trunk again. You could then put your patch into an own flyspray entry, link this entry as a related task and try to find a working solution.
Comment by whocares (Lutzero) - Tuesday, 22 June 2010, 19:04 GMT
r27055 = fixed. No more flac skipping. Don't have mpc files but thats another thread ;)

Loading...