Rockbox

Tasklist

FS#11420 - [PATCH] Crash during autodetection

Attached to Project: Rockbox
Opened by judas_iscariote (judas_iscariote) - Saturday, 19 June 2010, 23:19 GMT
Last edited by Dominik Riebeling (bluebrother) - Tuesday, 22 June 2010, 20:15 GMT
Task Type Patches
Category Rbutil
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Rbutil SVN
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If you lauch RockboxUtility without any device plugged in , and click on the autodetect box, it crashes because you are usb_close()'ing a NULL.

libusb couldn't open USB device /dev/bus/usb/001/001: Permission denied.
libusb requires write access to USB device nodes.
Program received signal SIGSEGV, Segmentation fault.




This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Tuesday, 22 June 2010, 20:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  I've redone this change by myself because our policy requires real names for contributors. However, thanks for spotting it and pointing it out.
Comment by Dominik Riebeling (bluebrother) - Sunday, 20 June 2010, 09:38 GMT
While the change is correct I can't see why this should cause a problem -- on all systems I've tried libusb finds at least the root hubs so the usb_open() call doesn't fail. As far as I understand the problem is your setup not having the correct permissions and is not related to devices plugged in or not. Fixing this issue would be good in any case.

However, I have two problems accepting this patch:
1. Rockbox has a real name policy. You haven't provided your real name to Flyspray.
2. You are not following the Rockbox coding style (tabs instead of spaces).

Loading...