Rockbox

Tasklist

FS#11455 - Text Viewer: StatusBar randomly appears

Attached to Project: Rockbox
Opened by Hunter Ragnarok (G4Oblivion) - Saturday, 03 July 2010, 22:06 GMT
Last edited by Steve Bavin (pondlife) - Tuesday, 06 July 2010, 09:43 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To Yoshihisa Uchida (Uchida)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I set "Show statusbar" to No it will randomly appear when I am browsing a text file.
I can get the statusbar to appear by locking my iPod or waiting a few seconds on a page.
Sometimes the statusbar will turn itself back on too.

I believe this was caused by r27194 or one of the ones right after or right before it.
This task depends upon

Closed by  Steve Bavin (pondlife)
Tuesday, 06 July 2010, 09:43 GMT
Reason for closing:  Fixed
Comment by Yoshihisa Uchida (Uchida) - Sunday, 04 July 2010, 12:25 GMT
I confirmed this problem and sends the patch file.
please confirm it.
Comment by Hunter Ragnarok (G4Oblivion) - Sunday, 04 July 2010, 17:02 GMT
I don't have a compiler setup. I currently only have my laptop.
Laptop uses windows so it would take 5 hours to install the eabi compiler.
My laptop would burn itself up if I left it on that long without a break and I don't think I would have tat time anyway.
Sorry I can't test. If someone else has this problem and has free time please test.
Comment by Yoshihisa Uchida (Uchida) - Monday, 05 July 2010, 12:16 GMT
commits my patch (r27293). please confirm the latest version.
Comment by Teruaki Kawashima (teru) - Monday, 05 July 2010, 14:23 GMT
I have a simillar issue.
if I use "Base Skin" and set "Show Statusbar" in the text viewer's option to "Yes", the statusbar overlaps the skin and it doesn't look nice (see attached dump.png).
gigabeat x, r27293.
   dump.png (22.7 KiB)
Comment by Hunter Ragnarok (G4Oblivion) - Monday, 05 July 2010, 22:07 GMT
Problem has been fixed.

Loading...