Rockbox

Tasklist

FS#11458 - Fix test_codec on low memory targets

Attached to Project: Rockbox
Opened by MichaelGiacomelli (saratoga) - Monday, 05 July 2010, 04:07 GMT
Last edited by MichaelGiacomelli (saratoga) - Tuesday, 06 July 2010, 00:11 GMT
Task Type Patches
Category Codecs
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

test_codec currently only works when the test file is smaller then the audio buffer. This makes it fail on low memory targets. This patch corrects that.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Tuesday, 06 July 2010, 00:11 GMT
Reason for closing:  Accepted
Additional comments about closing:  Accepted in r27303.
Comment by Rafaël Carré (funman) - Monday, 05 July 2010, 20:51 GMT
Clipv1 results: http://pastie.org/1031736

MP3 and aache are broken, it seems that decoding stops at the first rebuffer
Comment by MichaelGiacomelli (saratoga) - Monday, 05 July 2010, 21:06 GMT
Fixes MP3 for me (have to try AAC-HE yet).
Comment by MichaelGiacomelli (saratoga) - Monday, 05 July 2010, 21:43 GMT
AAC-He problems are due to AAC-He not working on low memory targets, so I think its not a bug in test_codec (or if it is we won't know until HE is fixed).
Comment by Rafaël Carré (funman) - Monday, 05 July 2010, 23:19 GMT
With v2: http://pastie.org/1031920

Looks ok, please commit we can still fix AAC-HE later

Loading...