Rockbox

Tasklist

FS#11468 - Ipod nano 2G full freeze, message "*PANIC* Stkov nand", in plugins folder

Attached to Project: Rockbox
Opened by Billy (ipawdnano2g) - Friday, 09 July 2010, 06:21 GMT
Last edited by Frank Gevaerts (fg) - Monday, 06 September 2010, 14:39 GMT
Task Type Bugs
Category Build environment
Status Closed
Assigned To No-one
Operating System iPod Nano 2G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Firmware: Ipod nano 2G v. r27354-100709

Steps: Manual unpack of .zip file to ipod directory
Installed bootloader as per manual

- Went to PLUGINS/DEMOS
- Then after opening demos file, instant freeze;
-screen goes white
- message is " *PANIC* Stkov nand"
- Can only be fixed by hard reset (menu + select button)

NB- the above freeze ALSO occurs in PLUGINS/GAMES during the
boot-up of SOME GAMES. However, of all the games I tried,
"chopper" game does not freeze.

-Freeze also occurred exactly the same in ROCKBOX version 27345-100708 daily build. Manual installatation.


Repeatable: YES, is repeatable

Files and relevant information:
- Nil
- Freeze

I'm thinking this has something to do with a lack of RAM, or bad formatting?
Just putting it out there...


Thanks a lot for your time.
This task depends upon

Closed by  Frank Gevaerts (fg)
Monday, 06 September 2010, 14:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  This should be fixed with r28011
Comment by Matt (archeee) - Sunday, 11 July 2010, 17:33 GMT
I can confirm this bug (r27350).

The ipod nano unfailingly shows the "Stkov nand" panic message in multiple contexts (when selecting a menu item) approximately 30-60 seconds after startup. I have not succeeded in getting the version above to work for more than a minute or two.

FWIW, I built an older version of the firmware - r26850 (June 3, 2010). The nano works fine with that firmware. I have not yet had a chance to track down the faulty commit in past month's SVN logs.

Thanks to everyone who works on rockbox!
Comment by Markus P. (progrox) - Thursday, 15 July 2010, 04:22 GMT
I can confirm this as well. Happens with both the iLoader bootloader and the Rockbox one.

Using the latest daily build which is r27424.
Comment by phll (zelkova20) - Friday, 30 July 2010, 13:32 GMT
yo matt can i have that firmware
also i believe the crash is due to RAM consumption by rockbox
i let it sit idle for a while but when i try to do 2 things at once it freezez near immediat
also can i have a copy of that firmware pleeeeeeeeeaaaaaasse, i just got rockbox and i dont want it to suck
Comment by phll (zelkova20) - Friday, 30 July 2010, 21:12 GMT
my ipod does the stkov nand ever since the last update it suck and is not getting better i need the old firmware matt please,please?
Comment by Brady (gametwizter) - Sunday, 01 August 2010, 01:04 GMT
I also can confirm it.

@Matt or anyone else: Could you send that firmware version to me, or possibly put it somewhere where everyone with the problem can access it. Thanks.

Using build r27644 on iPod Nano G2.
Comment by John Doe (xvan) - Wednesday, 18 August 2010, 06:42 GMT
This is the -r26850. Worked with my nano2g, but build it following the manual and using the automatic tools, not knowing what i was doing... (you know while compiling the compiler, and using the default options for the build).
Comment by Alexey Polkhirev (0x2102) - Thursday, 19 August 2010, 19:03 GMT
This problem will becorrected, if the iPod is switched off in the regular way by timeout.
Comment by Markus P. (progrox) - Friday, 20 August 2010, 07:13 GMT
As of r27841, I am not getting the crash any longer. Thank you Michael!
Comment by Markus P. (progrox) - Friday, 20 August 2010, 07:22 GMT
Nevermind. It all worked fine, but going into Theme Settings after a few minutes of fiddling still gave me a *panic*.
Comment by John Doe (xvan) - Thursday, 26 August 2010, 05:28 GMT
Here is the -r268450 for nano2g, works 4 me.
http://uploading.com/files/6mbd634a/rockbox.zip/
Comment by Hunter Ragnarok (G4Oblivion) - Tuesday, 31 August 2010, 04:23 GMT
I've built the latest release (r27956) and did a temporary fix on it to stop the crash. You can download it here http://www.mediafire.com/?2m2ql9atvp9q4q4
I'll post a .diff of what I did. All I did was remove "call_storage_idle_notifys(false);"

Loading...