Rockbox

Tasklist

FS#11469 - FM Radio Station name does not update when changing stations

Attached to Project: Rockbox
Opened by Richard Schofield (reszerve) - Saturday, 10 July 2010, 21:15 GMT
Last edited by Jonathan Gordon (jdgordon) - Monday, 16 August 2010, 12:08 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When changing stations in the FM radio screen, the station changes, the station frequency display updates, but the station name display stays stuck on whatever station name was first displaying.

If you exit the FM radio screen, then re-enter it, the station name updates to the current selected station.

Issue occurs regardless of whether RockBox just booted, or has already been playing tracks etc. and whether it is the first or later times the FM radio is used.

Daily build r27303-100706 and before did not have this issue, station name updates correctly.

All daily builds tested since this one up to the current r27365-100710 have this issue.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Monday, 16 August 2010, 12:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  r27827
Comment by Richard Schofield (reszerve) - Saturday, 10 July 2010, 21:49 GMT
Additional Info in case it's relevant: using default FM Screen, custom SBS. Haven't tested removing the custom SBS.
Comment by Václav Brožík (pabouk) - Monday, 12 July 2010, 16:55 GMT
I confirm this bug on H120. The latest build tested: r27404-100712.
The first line of FM screen (after the status bar) with preset number and name does not change when switching presets.
Everything else works well.

Tested with cleared settings and the default FM screen.

The most probable cause of the problem is r27304:
http://svn.rockbox.org/viewvc.cgi?view=rev;revision=27304
Comment by Marek Salaba (salaba) - Sunday, 18 July 2010, 15:08 GMT
I confirm this bug on Sansa Fuse v2 with last daily build.
Comment by Václav Brožík (pabouk) - Tuesday, 20 July 2010, 16:14 GMT
The bug still persists in the latest build r27503-100720 (tested on H120).
Comment by Ralf Erbel (jago) - Monday, 02 August 2010, 13:43 GMT
I've spotted an other issue that occured with r27304.
I use the album art tags (%Cl,%C) in my fms to display station logos.
Before r27304 this worked without any problems.
But now the viewport for the albumart is not anymore cleared before a
new station logo is drawn. They are all just copied each over the other.

Loading...