Rockbox

Tasklist

FS#11496 - Rockbox Utility fails to create voice file for the current build.

Attached to Project: Rockbox
Opened by Tuukka Ojala (tuojal) - Sunday, 25 July 2010, 09:55 GMT
Last edited by Nils Wallménius (nls) - Sunday, 13 February 2011, 10:39 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Rbutil 1.2.7
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When attempting to create the voice file using SAPI the encoding process aborts with the following message:
Encoding of C:/users/Tuukka/LOCALS~1/Temp/rbvoice//LANG_NOT_PRESENT.wav failed

The same happens after cleaning the cache.
This task depends upon

Closed by  Nils Wallménius (nls)
Sunday, 13 February 2011, 10:39 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Seems fixed, no reply for months anyway
Comment by Marek Salaba (salaba) - Sunday, 22 August 2010, 08:26 GMT
Yes, I report same error when I using RBUtil 1.2.7. In each situation failed me on other file.
When I use SVN verison of RBUtil from here http://www.alice-dsl.net/dominik.riebeling/rockbox/rbutil/
there is no problem.
Comment by Dominik Riebeling (bluebrother) - Sunday, 22 August 2010, 12:15 GMT
which svn version are you using? Please tell the revision number that is part of the file name of the download (don't check the About dialog, that is likely to be wrong). Are you using a multi core machine?
Comment by Marek Salaba (salaba) - Sunday, 22 August 2010, 12:47 GMT
Error is from 1.2.7 r27062 on Windows XP.
I using SVN r25567 on Windows XP - there is no problem.
I have not multiple core PC.
Comment by Dominik Riebeling (bluebrother) - Monday, 23 August 2010, 20:59 GMT
That's interesting -- as far as I can see the issue arised after the introduction of multithread support for voice file generation and I suspected this to be an issue on multicore machines only. The svn version you're using is pretty old, and the one provided at my website is currently r26978 (which is pretty close to 1.2.7), so simply putting the link here doesn't tell anything.
Comment by Tuukka Ojala (tuojal) - Tuesday, 24 August 2010, 04:32 GMT
My computer has a dual core processor. However, with single-core processor and ESpeak the voice generation works fine. (Tested on my friend's relatively old laptop)
Comment by Steve Clarke (trumpton) - Wednesday, 01 September 2010, 22:11 GMT
I've seen something similar when using the Cepstral swift application to encode voices on Linux mandriva 2010.
As the application is a single user license, the Create Voice File function never manages to create all files (i.e. some of them are left empty).
I created a script as a shim for swift, which contained the following:

#!/bin/sh
#
# Introduce a sleep after the swift program execution
# so that it can run properly.
#
/opt/swift/bin/swift "$1" "$2" "$3" "$4" "$5" "$6" "$7" "$8" "$9"
sleep 1

The sleep 1 seemed to stop the program tripping over its own single license, and everything worked OK.

Steve
Comment by Steve Clarke (trumpton) - Sunday, 05 September 2010, 12:01 GMT
I've seen something similar when using the Cepstral swift application to encode voices on Linux mandriva 2010.
As the application is a single user license, the Create Voice File function never manages to create all files (i.e. some of them are left empty).
I created a script as a shim for swift, which contained the following:

#!/bin/sh
#
# Introduce a sleep after the swift program execution
# so that it can run properly.
#
/opt/swift/bin/swift "$1" "$2" "$3" "$4" "$5" "$6" "$7" "$8" "$9"
sleep 1

The sleep 1 seemed to stop the program tripping over its own single license, and everything worked OK.

Steve
Comment by Dominik Riebeling (bluebrother) - Tuesday, 14 September 2010, 20:12 GMT
I tried to reproduce this issue but it worked fine for me. My current assumption is that it's a Windows issue, however, using MS Anna worked fine. This leads me to the suspicion that it's related to the voice used, especially to commercial voices that somehow don't like getting called multiple times using the same program, like Steve already mentioned. Since the voice won't tell us about this the only solution I can think about is to add an option that disables multithreading support in voice file generation. Can you guys having problems please state

- the used OS
- the used voice
- if the voice is commercial or not

to (hopefully) backup my theory? Thanks.
Comment by Marek Salaba (salaba) - Monday, 18 October 2010, 08:41 GMT
Hello.

Now I using Rockbox Utility 1.2.8 and problem is out !!!
On version 1.2.7 still faild on same PC.

Salaba
Comment by Dominik Riebeling (bluebrother) - Monday, 18 October 2010, 17:21 GMT
By "out" your referring to "doesn't occur anymore"? That would be really strange since there were no changes in that part of the code between those two releases.

Loading...