Rockbox

Tasklist

FS#11526 - Use of %Vb/f (viewport foreground and background) break WPS or RWPS on X5

Attached to Project: Rockbox
Opened by Marianne Arnold (pixelma) - Monday, 09 August 2010, 09:53 GMT
Last edited by Jonathan Gordon (jdgordon) - Tuesday, 10 August 2010, 14:15 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System iAudio X5
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The X5 has a colour display and a greyscale remote, hence it was possible to set a viewport foreground and background (as RGB on main screen and as one of the greyshades for the remote) - this is broken in current SVN builds.

A WPS for the main screen which uses %Vb(FF00FF) is rejected by the parser and you get the default WPS, %Vb(3) which would be wrong for colour is rejected as well. The theme site also only lists a few themes - there should be as many as e.g. the 20GB H10 ones but there are less than the 160x128 greyscale targets have. Themes/WPSs listed are all without %Vb/f.

An RWPS which uses %Vf(0) is rejected as well. Unfortunately the cabbiev2.rwps uses %Vb/f in one place and doesn't show up (can't remember completely why it was done this way but that shouldn't matter here). The same .wps works fine on the M3 as main wps and also on the M5 as RWPS... This last fact leads me to assume that it could have something to do with the different formats the value of %Vb/f needs (RGB and greyshade).

The problem is visible in a simulator and was also present in revision 27663, one before "r27664: make grey targets reject viewport colours if they are more than one letter (i.e %Vb(333333) )". It was also confirmed or reported by Temik on IRC who saw it on target.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Tuesday, 10 August 2010, 14:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r27768.

Loading...