Rockbox

Tasklist

FS#11538 - aac files not even visible in list

Attached to Project: Rockbox
Opened by Harry Hirsch (capreolus) - Saturday, 14 August 2010, 17:19 GMT
Last edited by MichaelGiacomelli (saratoga) - Monday, 16 August 2010, 19:54 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Release 3.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

aac files don't even show up in files list. No chance to start them. example file attached. Sansa Clip+; r27817
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Monday, 16 August 2010, 19:54 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  .aac files are not the same as AAC. We support AAC in MP4 files as per the standard. Raw AAC streams are something else and unsupported since theres no reason for them to exist.
Comment by Nils Wallménius (nls) - Sunday, 15 August 2010, 08:32 GMT
Which file list does it not show up in? the database or the file browser or something else?

edit: aac is not in the list of supported extensions so that's why it doesn't show up and isn't playable
are these files different from m4a or just the extension?

edit again: a simple rename to m4a doesn't do it so we need to modify or add a new parser for this format to be able to play it
Comment by Harry Hirsch (capreolus) - Sunday, 15 August 2010, 09:31 GMT
The aac file doesn't show up in the filebrowser. In database I'm not sure, because there are several other files with the same and similar tags. If you want to to know it, I'll look it up more thoroughly.

As the feature comparison page says "AAC/MP4 Decoding: yes" I was assuming that aac was suppurted. If thats not the case, it's not important to me; just wanted to report it. The file is not renamed.
Comment by Magnus Holmgren (learman) - Sunday, 15 August 2010, 12:37 GMT
AAC in an MP4 container is supported. AAC in ADTS is not, however.

Loading...