Rockbox

Tasklist

FS#11563 - Rbutil fails to autodetect, Mac.

Attached to Project: Rockbox
Opened by patrick (phixxor) - Monday, 23 August 2010, 04:27 GMT
Last edited by Dominik Riebeling (bluebrother) - Sunday, 20 March 2011, 10:58 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Rbutil 1.2.7
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

For the Sansa Clip+ on Mac OS X

Opened Rockbox Utils, configuration dialog pops up.
Browse to select the clip+ ("/Volumes/SANSA CLIPP"

Click "autodetect" gives this error and grays out all the selectable media players.

Screenshot provided

IRC Conversation:
<phixxor> "Unless you changed this installation will fail!"
<phixxor> changed what?
* BHSPitMonkey (~stephen@unaffiliated/bhspitmonkey) has joined #rockbox
<phixxor> you might want to improve your error messages
<JdGordon|> where the heck did that come from?
<phixxor> trying to autodetect
<phixxor> this page is helping me though: http://www.rockbox.org/wiki/GraphicalInstall specifically "Ipod and Sansa players require you to have administrator permissions."
<phixxor> does that mean I need to run rockbox utility as an admin somehow?
<saratoga_> i don't think its needed on the clip+, just the older sansas
<phixxor> saratoga_, interesting. what could be the problem then?
<saratoga_> what was your problem?
<phixxor> scroll up: starting from "Unless you changed this installation will fail!"
<saratoga_> i read that, i just don't know what you're talking about
<phixxor> I'll take a screenshot
<saratoga_> can't you just describe your problem in words
<phixxor> already did
<phixxor> i clicked autodetect and got that error
<phixxor> http://imgur.com/rc4Kp
<saratoga_> never seen that before, but random guess: is that path correct?
<JdGordon|> please file a bug with that image
<phixxor> can you point me to your bug filing system?
<JdGordon|> maybe it doesnt like the space in the path name
<phixxor> i tried with an underscore too -- should I try a \

end of IRC Conversation
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Sunday, 20 March 2011, 10:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  should be fixed with r29621.
Comment by Dominik Riebeling (bluebrother) - Monday, 23 August 2010, 21:02 GMT
<phixxor> you might want to improve your error messages

No, thanks -- the error message is good enough. The problem is that there seems to be a bug when displaying the error message which cuts of the important part of it. So I'd rather fix the error message display than "improving" the message itself.

Loading...