Rockbox

Tasklist

FS#11572 - No backdrop in FM Screen

Attached to Project: Rockbox
Opened by Carsten Eckartsberg (AsusFreak) - Thursday, 26 August 2010, 14:33 GMT
Last edited by Jonathan Gordon (jdgordon) - Sunday, 17 October 2010, 10:26 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi.

While coding the AF_Squeeze theme I got a problem placing the background image in the FM Screen.

My AF_Squeeze.fms begins with:

# Disabling the custom statusbar in the FM Screen
%wd

# Should show the backdrop
%X(bg.bmp)

But if I do so the backdrop is not shown. Only when I go to the preset screen and come back to FM Screen or (!) saved a preset before (!) then the background is shown.

Could you please take a look at it?

I am using the current r27890 on my D2 with OF V3.13.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Sunday, 17 October 2010, 10:26 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  The skin buffer is full... It really needs two things (both planned)
1) better splash messages
2) swap out backdrops when they arnt being used (i.e load the fm backdrop into the same buffer as the wps because they can never be displayed together)

Loading...