Rockbox

Tasklist

FS#11591 - Screen corruption after switching themes

Attached to Project: Rockbox
Opened by Marianne Arnold (pixelma) - Tuesday, 31 August 2010, 17:50 GMT
Last edited by Marianne Arnold (pixelma) - Wednesday, 13 October 2010, 12:28 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On my Ondio I sometimes see screen corruption in the WPS after switching themes and in different severety. Often it is a slightly misplaced progressbar (one or two pixels left or up or down) or a missing row of the bitmap and/or some extra pixels often in the top left corner of the screen. The look changes after switching or only reloading a theme - so e.g. the default cabbiev2 can look completely "normal", or have some slight glitches as described to looking completely garbled as shown below (the look of this example survived leaving the WPS, turning on the screenshot function, re-entering the WPS and even a reboot - it went away after switching themes).

A few people have reported similar issues with cabbiev2 on a Clip, often described as screen corruption in the top bar which is the bitmap progressbar. I still need to find out if it happens in all themes and when exactly this started. It could be wrong but I wouldn't be surprised if the issue was related to any other theme problems currently, e.g.  FS#11590  or  FS#11562 ).

This task depends upon

Closed by  Marianne Arnold (pixelma)
Wednesday, 13 October 2010, 12:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  I don't experience these anymore.
Comment by Marianne Arnold (pixelma) - Friday, 03 September 2010, 07:36 GMT
Since the two examples (Archos and Clip) are monochrome ones that use statically loaded images which don't show up, I could imagine that this bug is related: " FS#11550  - %x() image "drawn below" %pb() in the same viewport doesn't show up".

On my Ondio the "background" which is loaded with %x() doesn't show up even if the rest of cabbiev2 is recognisable. Plus: I haven't encountered something similar with my own wps so far which uses %x in one case but only in an own viewport and without anything drawn over, the graphic even shows up correctly.
Comment by Frank Gevaerts (fg) - Saturday, 09 October 2010, 21:49 GMT
I can't seem to reproduce this on my Clip. Any hints?
Comment by Humberto Santana (hhannah) - Saturday, 09 October 2010, 23:09 GMT
I'm not sure if this is really related to the same issue, but *sometimes* on an ipod video, when switching through themes (three or more times, sometimes two... sorry I haven't really identified a pattern), the themes begin to behave as if there was no album art present, i.e. it enters the no album art conditionals (if the theme is designed that way). I would say almost every time I saw this happening, a theme that displays album art in the sbs was loaded at some point of the theme switching. Also, the album art sizes in the different wps's changed.
Two things to mention: 1- The only theme that recognizes album art when the problem occurs, is the theme loaded at start up (that is, if you load that theme after the problem occurs). Of course, if you reboot, the first theme loaded would always work correctly. 2- Although when the problem occurs, album art is not recognized as present in the WPS, the SBS would indeed recognize it and show it correctly (when the problem occurs on a theme that displays AA in the sbs)
Comment by Marianne Arnold (pixelma) - Sunday, 10 October 2010, 20:43 GMT
Frank,

it may have been fixed in one of last week's theme commits. Amiconn told me he didn't see it anymore recently, bertrik said the same. I can look at it more properly now that the hang on the Ondio is fixed and will give it a bit of testing the next days and close the bug report if I don't encounter it anymore.

Loading...