Rockbox

Tasklist

FS#11598 - Rbutil detects wrong drive as iPod.

Attached to Project: Rockbox
Opened by Hunter Ragnarok (G4Oblivion) - Thursday, 02 September 2010, 16:53 GMT
Last edited by Dominik Riebeling (bluebrother) - Saturday, 21 December 2013, 12:33 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System iPod Nano 2G
Severity Low
Priority Normal
Reported Version Rbutil 1.2.7
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When plugging in a USB flash drive and my iPod Nano 2G (I do not have other devices to test)
Rbutil detects my USB drive letter as my iPod and tries to install Rockbox on my flash drive.

Rbutil - v1.2.7
OS - Windows Vista 32bit

Reproduce:

Attach a USB flash drive to a USB port on your computer. Remember drive letter.
Attach your Ipod. Remember drive letter.
Run Rbutil.
Run Auto-detect.
It should say something like: Apple Ipod Nano (2nd gen) (Unstable) at F:\

My USB flash drive is (F:\) and my Nano is (E:\).
Not sure if this matters but I have Portableapps on my USB flash drive.


Note: The "I" and 'p" in Ipod should be lowercase "i" and uppercase "P"
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Saturday, 21 December 2013, 12:33 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Player detection has been reworked. If this is still an issue please open a new task (note that the latest Rockbox Utility release still exhibits this behaviour, to test you need to use a development version)
Comment by Hunter Ragnarok (G4Oblivion) - Thursday, 02 September 2010, 16:55 GMT
Forgot a piece of information.

I have a .rockbox folder on my USB flash drive as a backup.
I'm not sure if that matters or not.
Comment by Dominik Riebeling (bluebrother) - Thursday, 02 September 2010, 17:21 GMT
That *does* matter and it's the reason for this behaviour. Rockbox Utility uses various measures to detect a Rockbox player. One of these measures is to check for a folder .rockbox -- it doesn't make much sense to have such a folder on a non-Rockbox device (except, of course, for backup purposes, but in that case you can also use the backup functionality of Rockbox Utility and store the backup on some other drive. The installation will get placed in a zip file by that backup function, saving space and preventing such issues).

An improved device detection (which I'm planning to do but have no ETA when I might actually find the time for it) could "fix" this issue. However, I don't consider this a bug.

Note: while Apple uses the casing "iPod" it has been decided years ago to use "Ipod". This was done in the context of the manual, and it doesn't make sense to use different capitalization in different placed of Rockbox, hence Rockbox Utility uses "Ipod". The front page unfortunately disagrees with this.
Comment by Hunter Ragnarok (G4Oblivion) - Thursday, 02 September 2010, 17:33 GMT
Removing the .rockbox folder seemed to have worked.
I put my .rockbox folder on my USB because its portable and easy to find. I was going to compress it to a .7z but I forgot.

What I don't get is I had a .rockbox folder in on my Nano at the time and it decided that the USB was the correct one to go with.
Making it check for a .rockbox folder makes sense but needs other ways of making sure that it got the correct device.

I look forward to the new device detection whenever it comes out.

Loading...