Rockbox

Tasklist

FS#11603 - Rockboy "Not Enough Memory" bug on Fuze v2 while playing music

Attached to Project: Rockbox
Opened by bohwaz (bohwaz) - Sunday, 05 September 2010, 12:47 GMT
Last edited by Paul Louden (Llorean) - Sunday, 05 September 2010, 14:54 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Manufacturer: as3525
Version: r27999-100905
Binary: rockbox.sansa

There is a bug in the current build (and since quite some time) for the Fuze V2. When you are playing music and trying to load a game with rockboy (using the Files browser), it will show an error for games which seems too big for the memory.

First it displays "Not enough memory" and then "Plugin returned error".

Games where the bug happens: Legend of Zelda - Link's Awakening, Metroid II, etc.

There is some games where the bug doesn't happen: Mario Land,Tetris, etc.

If I stop the music playing (like by playing a video and the exiting) it's working. I think that rockboy should stop playing before launching game, to free memory.
This task depends upon

Closed by  Paul Louden (Llorean)
Sunday, 05 September 2010, 14:54 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Some people want to listen to their music while playing games. This allows people to play small games with their music, or choose to stop music themselves to play large games.

Loading...