Rockbox

Tasklist

FS#11607 - Enable USB on AMSv2 using Nano2g driver

Attached to Project: Rockbox
Opened by Rafaël Carré (funman) - Monday, 06 September 2010, 18:25 GMT
Last edited by Rafaël Carré (funman) - Wednesday, 08 September 2010, 05:24 GMT
Task Type Patches
Category Drivers
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Please test on nano2g to see if it still works

Also it doesn't seem to work correctly on Clip+
This task depends upon

Closed by  Rafaël Carré (funman)
Wednesday, 08 September 2010, 05:24 GMT
Reason for closing:  Out of Date
Additional comments about closing:  usb-drv-as3525v2.c now works

ideally both drivers should be merged
Comment by Rafaël Carré (funman) - Monday, 06 September 2010, 21:43 GMT
Clipv2 & Fuzev2 works on Linux but not on Windows.

Also Fuzev2 doesn't seem to expose the µSD slot.

(I don't have the fuzev2 handy so can't reproduce)
Comment by Daniel Kalle (DonDan) - Monday, 06 September 2010, 22:11 GMT
I made a few tests with the Fuze2 (r28016M) on a Windows 7 machine and both Internal and µSD works. The file transfer is even slightly faster than with the OF! yeahh! OF: write 4.3 MB/s, read 6.0 MB/s; RB: write 4.5 MB, read 6.3 MB/s; The checksums of the transferred files always match. Nice. Drop a line if you want me to make some other tests regarding USB on Fuze2.
Cheers
Comment by Rafaël Carré (funman) - Tuesday, 07 September 2010, 06:08 GMT
- implement usb_phy_reset() for amsv2

(no changes for nano2g)

Clip+ mounts fine on Linux, will test on windows
Comment by Rafaël Carré (funman) - Tuesday, 07 September 2010, 06:12 GMT
v2 seems to break clipv2 on linux
Comment by Rafaël Carré (funman) - Tuesday, 07 September 2010, 06:18 GMT
Clip+ mounted fine on Vista on the second attempt
Comment by Luca Leonardo Scorcia (LucaLeonardoScorcia) - Tuesday, 07 September 2010, 07:39 GMT
Patch V2 on FuzeV2 works great on Win7. Shows both uSD and internal storage, it's fast, and it's ready to rock. Congratulations!
Comment by Rafaël Carré (funman) - Tuesday, 07 September 2010, 16:33 GMT
Fix bootloader build
Comment by Rich Moll (Drise) - Tuesday, 07 September 2010, 23:30 GMT
Works on Fuze v2 on windows 7 64 bit.

Loading...