Rockbox

Tasklist

FS#11630 - Rockbox shows WPS backdrop instead of menu backdrop

Attached to Project: Rockbox
Opened by Václav Brožík (pabouk) - Thursday, 16 September 2010, 09:11 GMT
Last edited by Jonathan Gordon (jdgordon) - Sunday, 19 September 2010, 12:56 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

First observed on r28078-100914
Last checked just now on r28092-100916

Right after start Rockbox shows WPS backdrop in menu (even if WPS was not shown yet).
Loading a different theme or clearing backdrop solves the problem.
After restart the problem appears again.

Observed on H120. Tested with cleared settings.
The latest daily build where the problem does not appear is r28070-100913 so the problem was probably introduced by one of the Jonathan Gordon's commits r28073 - r28075 modifying the skin engine.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Sunday, 19 September 2010, 12:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r28116
Comment by federico pelupessy (fip) - Friday, 17 September 2010, 10:46 GMT
I can confirm this is also the case on X5L and X5L-sim..
Comment by Marianne Arnold (pixelma) - Friday, 17 September 2010, 22:49 GMT
Confirmed on my M5 and also tested that it is visible in an M5 sim with e.g. cabbiev2. Another, probably related thing is that a bmp "set as backdrop" globally doesn't appear usually, it comes up if you leave the USB screen though, sometimes together with some screen corruption (one time I had some garbage pixels at the top and the Rockbox logo shifted to the left with the cabbiev2 backdrop).

The global backdrop problem was also noticed on a Gigabeat S but it didn't seem to show the WPS-backdrop-in-menu-problem, I didn't understand why, maybe it is SBS related. There's some talk about it by me and AlexP in the logs of September 17th in bits and pieces starting at around 10 and going on to the afternoon (link to an example: http://www.rockbox.org/irc/log-20100917#12:44:42 ).
Comment by Tiago (vspeed) - Saturday, 18 September 2010, 17:48 GMT
same happened to me. if I clear the backdrop, after going to WPS, the menu backdrop becomes the WPS background.

Loading...