Rockbox

Tasklist

FS#11642 - Data abort after booting (with update database)

Attached to Project: Rockbox
Opened by Benjamin Drung (bdrung) - Friday, 24 September 2010, 14:59 GMT
Last edited by MichaelGiacomelli (saratoga) - Sunday, 17 April 2011, 23:15 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I setup rockbox to resume where it stops. When I power the player of when playing, the player will continue to play on powered on.

I copied new files on the device, started playing a song. After the database recreation, I power it off and on again to have the database updated, but instead I got this error message shown:

Data abort
at 308007B0
FSR 0x8
(domain 8, fault 8)
address 0x902C1A78

Player: Sansa Clip+
Rockbox version: r28154-100923
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Sunday, 17 April 2011, 23:15 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Likely to have been fixed at some point during the SD driver clean up.
Comment by amaury pouly (pamaury) - Saturday, 09 October 2010, 23:47 GMT
Can you be a little bit more precise ? I try to reproduce it following these steps but it doesn't work:
1) Enable database, enable auto-update (do you have something more ? load to ram ? ...)
2) Set startup screen to resume playback
3) Reboot to OF and copy new files
4) Reboot to rockbox and start playing a file (one of the newly added ? from file browser or database ?)
5) Wait for the update process to complete
6) Reboot
7) Wait for database commit
8) Rockbox automatically resume playback
Comment by Benjamin Drung (bdrung) - Thursday, 27 January 2011, 22:47 GMT
Sorry for the big delay. The mail got "lost" in my todo directory.

I had load to ram enabled.

Since the upgrade to Rockbox 3.7 I haven't experience the crash any more. You can close this bug for now. I will report back if I hit it again.

Loading...