Rockbox

Tasklist

FS#11648 - Settings are not saved after loading config file.

Attached to Project: Rockbox
Opened by Teruaki Kawashima (teru) - Saturday, 02 October 2010, 05:50 GMT
Last edited by Jonathan Gordon (jdgordon) - Sunday, 03 October 2010, 05:44 GMT
Task Type Bugs
Category Settings
Status Closed
Assigned To No-one
Operating System Gigabeat F/X
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

1. Open Settings->Theme Settings->Browse Theme Files.
2. Select theme other than currently used.
3. shutdown and reboot.
the theme is not changed to selected.
if i select a font after loading theme and then shutdown and reboot, theme is changed to selected.

r28120 seems the cause. reverting the change solve the issue.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Sunday, 03 October 2010, 05:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r28201
Comment by Frank Gevaerts (fg) - Saturday, 02 October 2010, 13:24 GMT
At first sight I think making that settings_save() call conditional on "apply" might be the proper solution
Comment by Doug Peterson (DougPeterson) - Sunday, 03 October 2010, 05:11 GMT
This may be related. For me, theme file changes are not being saved. The theme selection change occurs, but just is not saved. I can change the font or the wps separately and those changes are saved. I can save changes unrelated to themes to config.cfg, like record settings. This is happening on a Fuze V1 at 28159 and a Fuze V2 at 28200.

Loading...